{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-10110 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2015-10110 yet. Limit exposure of the affected software until one is available.","what":"CVE-2015-10110 is a low-severity cross-site scripting vulnerability in ruddernation TinyChat Room Spy Plugin, published on 1 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2015-10110 and fix it if it is affected.\n\nWhat it is: CVE-2015-10110 is a low-severity cross-site scripting vulnerability in ruddernation TinyChat Room Spy Plugin, published on 1 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2015-10110 in the wild and no public exploit code.\n\nAffected product: ruddernation TinyChat Room Spy Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-10110/ (Markdown: https://insights.sbomify.com/CVE-2015-10110/index.md)","id":"CVE-2015-10110","markdown":"https://insights.sbomify.com/CVE-2015-10110/index.md","name":"CVE-2015-10110","record":{"aliases":["GHSA-g5xh-jqqc-5j72"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"A cross-site scripting vulnerability in the TinyChat Room Spy Plugin allows remote attackers to inject malicious scripts via the room argument.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"room_spy","vendor":"tinychat"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability classified as problematic was found in ruddernation TinyChat Room Spy Plugin up to 1.2.8 on WordPress. This vulnerability affects the function wp_show_room_spy of the file room-spy.php. The manipulation of the argument room leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 1.2.9 is able to address this issue. The name of the patch is ab72627a963d61fb3bc31018e3855b08dc94a979. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-230392.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"ruddernation TinyChat Room Spy Plugin room-spy.php wp_show_room_spy cross site scripting","id":"CVE-2015-10110","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2015"},"n_packages":0,"n_references":3,"next":{"headline":"Watu Quiz Plugin Exam exam.php watu_exams sql injection","id":"CVE-2015-10111"},"packages":[],"prev":{"headline":"Video Playlist and Gallery Plugin wp-media-cincopa.php cross-site request forgery","id":"CVE-2015-10109"},"products":["TinyChat Room Spy Plugin"],"published":"2023-06-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["ruddernation"]},"summary":"A cross-site scripting vulnerability in the TinyChat Room Spy Plugin allows remote attackers to inject malicious scripts via the room argument.","url":"https://insights.sbomify.com/CVE-2015-10110/"}