# CVE-2015-10110: ruddernation TinyChat Room Spy Plugin room-spy.php wp_show_room_spy cross site scripting

> A cross-site scripting vulnerability in the TinyChat Room Spy Plugin allows remote attackers to inject malicious scripts via the room argument.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 1 Jun 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-g5xh-jqqc-5j72

## What is CVE-2015-10110?

CVE-2015-10110 is a low-severity cross-site scripting vulnerability in ruddernation TinyChat Room Spy Plugin, published on 1 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability classified as problematic was found in ruddernation TinyChat Room Spy Plugin up to 1.2.8 on WordPress. This vulnerability affects the function wp_show_room_spy of the file room-spy.php. The manipulation of the argument room leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 1.2.9 is able to address this issue. The name of the patch is ab72627a963d61fb3bc31018e3855b08dc94a979. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-230392.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2015-10110?

It affects 1 product.


Products: Tinychat Room Spy.

## How do I fix CVE-2015-10110?

No fix has been published for CVE-2015-10110 yet. Limit exposure of the affected software until one is available.

## Is CVE-2015-10110 being exploited?

There is no known exploitation of CVE-2015-10110 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-10110 and fix it if it is affected.

What it is: CVE-2015-10110 is a low-severity cross-site scripting vulnerability in ruddernation TinyChat Room Spy Plugin, published on 1 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-10110 in the wild and no public exploit code.

Affected product: ruddernation TinyChat Room Spy Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-10110/ (Markdown: https://insights.sbomify.com/CVE-2015-10110/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-10110
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-10110
- OSV: https://osv.dev/vulnerability/CVE-2015-10110

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-10110/
Summaries are generated and may contain mistakes; the official description above is the record.
