{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-10111 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2015-10111 yet. Limit exposure of the affected software until one is available.","what":"CVE-2015-10111 is a medium-severity vulnerability in Watu Quiz Plugin, published on 4 Jun 2023."},"fix_prompt":"Check this codebase for CVE-2015-10111 and fix it if it is affected.\n\nWhat it is: CVE-2015-10111 is a medium-severity vulnerability in Watu Quiz Plugin, published on 4 Jun 2023. \nExploitation: There is no known exploitation of CVE-2015-10111 in the wild and no public exploit code.\n\nAffected product: Watu Quiz Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-10111/ (Markdown: https://insights.sbomify.com/CVE-2015-10111/index.md)","id":"CVE-2015-10111","markdown":"https://insights.sbomify.com/CVE-2015-10111/index.md","name":"CVE-2015-10111","record":{"aliases":["GHSA-5fj5-hp4f-cw5m"],"analysis":null,"analysis_generated_by":null,"assigner":"VulDB","cpe":[{"product":"watu_quiz","vendor":"kibokolabs"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"A vulnerability was found in Watu Quiz Plugin up to 2.6.7 on WordPress. It has been rated as critical. This issue affects the function watu_exams of the file controllers/exam.php of the component Exam Handler. The manipulation of the argument quiz leads to sql injection. The attack may be initiated remotely. Upgrading to version 2.6.8 is able to address this issue. The patch is named bf42e7cfd819a3e76cf3e1465697e89f4830590c. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-230651.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Watu Quiz Plugin Exam exam.php watu_exams sql injection","id":"CVE-2015-10111","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":null,"year":"2015"},"n_packages":0,"n_references":3,"next":{"headline":"WooFramework Branding Plugin wooframework-branding.php admin_screen_logic redirect","id":"CVE-2015-10112"},"packages":[],"prev":{"headline":"ruddernation TinyChat Room Spy Plugin room-spy.php wp_show_room_spy cross site scripting","id":"CVE-2015-10110"},"products":["Watu Quiz Plugin"],"published":"2023-06-04","related":[{"cvss_score":8.5,"headline":"WordPress Watu Quiz plugin \u003c= 3.4.1.2 - SQL Injection vulnerability","id":"CVE-2024-53792","kev_date_added":null,"published":"2024-12-02"},{"cvss_score":7.6,"headline":"WordPress Watu Quiz plugin \u003c= 3.4.3 - SQL Injection Vulnerability","id":"CVE-2025-46242","kev_date_added":null,"published":"2025-04-22"},{"cvss_score":7.5,"headline":"Watu Quiz \u003c 3.3.8.2 - Reflected XSS","id":"CVE-2023-0428","kev_date_added":null,"published":"2023-02-21"},{"cvss_score":7.1,"headline":"WordPress Watu Quiz plugin \u003c= 3.4.2 - Reflected Cross Site Scripting (XSS) Vulnerability","id":"CVE-2025-30844","kev_date_added":null,"published":"2025-04-01"},{"cvss_score":7.1,"headline":"WordPress Watu Quiz Plugin \u003c= 3.3.9.2 is vulnerable to Cross Site Scripting (XSS)","id":"CVE-2023-30483","kev_date_added":null,"published":"2023-08-14"},{"cvss_score":6.8,"headline":"Watu Quiz \u003c 3.4.1.2 - Author+ Stored XSS","id":"CVE-2024-2640","kev_date_added":null,"published":"2024-07-12"},{"cvss_score":6.4,"headline":"Watu Quiz \u003c= 3.4.1 - Authenticated (Contributor+) Stored Cross-Site Scripting","id":"CVE-2024-0873","kev_date_added":null,"published":"2024-04-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2015-10111/"}