# CVE-2015-10111: Watu Quiz Plugin Exam exam.php watu_exams sql injection


- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 4 Jun 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-5fj5-hp4f-cw5m

## What is CVE-2015-10111?

CVE-2015-10111 is a medium-severity vulnerability in Watu Quiz Plugin, published on 4 Jun 2023. 

### Official description

A vulnerability was found in Watu Quiz Plugin up to 2.6.7 on WordPress. It has been rated as critical. This issue affects the function watu_exams of the file controllers/exam.php of the component Exam Handler. The manipulation of the argument quiz leads to sql injection. The attack may be initiated remotely. Upgrading to version 2.6.8 is able to address this issue. The patch is named bf42e7cfd819a3e76cf3e1465697e89f4830590c. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-230651.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2015-10111?

It affects 1 product.


Products: Kibokolabs Watu Quiz.

## How do I fix CVE-2015-10111?

No fix has been published for CVE-2015-10111 yet. Limit exposure of the affected software until one is available.

## Is CVE-2015-10111 being exploited?

There is no known exploitation of CVE-2015-10111 in the wild and no public exploit code.

## Other vulnerabilities in Watu Quiz Plugin

- [CVE-2024-53792](https://insights.sbomify.com/CVE-2024-53792/): WordPress Watu Quiz plugin <= 3.4.1.2 - SQL Injection vulnerability (high 8.5)
- [CVE-2025-46242](https://insights.sbomify.com/CVE-2025-46242/): WordPress Watu Quiz plugin <= 3.4.3 - SQL Injection Vulnerability (high 7.6)
- [CVE-2023-0428](https://insights.sbomify.com/CVE-2023-0428/): Watu Quiz < 3.3.8.2 - Reflected XSS (high 7.5)
- [CVE-2025-30844](https://insights.sbomify.com/CVE-2025-30844/): WordPress Watu Quiz plugin <= 3.4.2 - Reflected Cross Site Scripting (XSS) Vulnerability (high 7.1)
- [CVE-2023-30483](https://insights.sbomify.com/CVE-2023-30483/): WordPress Watu Quiz Plugin <= 3.3.9.2 is vulnerable to Cross Site Scripting (XSS) (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-10111 and fix it if it is affected.

What it is: CVE-2015-10111 is a medium-severity vulnerability in Watu Quiz Plugin, published on 4 Jun 2023. 
Exploitation: There is no known exploitation of CVE-2015-10111 in the wild and no public exploit code.

Affected product: Watu Quiz Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-10111/ (Markdown: https://insights.sbomify.com/CVE-2015-10111/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-10111
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-10111
- OSV: https://osv.dev/vulnerability/CVE-2015-10111

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-10111/
Summaries are generated and may contain mistakes; the official description above is the record.
