# CVE-2015-10112: WooFramework Branding Plugin wooframework-branding.php admin_screen_logic redirect

> An attacker can redirect users to malicious sites via the admin screen logic in the WooFramework Branding Plugin for WordPress.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 5 Jun 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-qj29-8vrc-6m34

## What is CVE-2015-10112?

CVE-2015-10112 is a medium-severity vulnerability in WooFramework Branding Plugin, published on 5 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A vulnerability classified as problematic has been found in WooFramework Branding Plugin up to 1.0.1 on WordPress. Affected is the function admin_screen_logic of the file wooframework-branding.php. The manipulation of the argument url leads to open redirect. It is possible to launch the attack remotely. Upgrading to version 1.0.2 is able to address this issue. The name of the patch is f12fccd7b5eaf66442346f748c901ef504742f78. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-230652.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2015-10112?

It affects 1 product.


Products: Woocommerce Wooframework Branding.

## How do I fix CVE-2015-10112?

No fix has been published for CVE-2015-10112 yet. Limit exposure of the affected software until one is available.

## Is CVE-2015-10112 being exploited?

There is no known exploitation of CVE-2015-10112 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-10112 and fix it if it is affected.

What it is: CVE-2015-10112 is a medium-severity vulnerability in WooFramework Branding Plugin, published on 5 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-10112 in the wild and no public exploit code.

Affected product: WooFramework Branding Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-10112/ (Markdown: https://insights.sbomify.com/CVE-2015-10112/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-10112
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-10112
- OSV: https://osv.dev/vulnerability/CVE-2015-10112

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-10112/
Summaries are generated and may contain mistakes; the official description above is the record.
