{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-10113 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2015-10113 yet. Limit exposure of the affected software until one is available.","what":"CVE-2015-10113 is a low-severity vulnerability in WooFramework Tweaks Plugin, published on 5 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2015-10113 and fix it if it is affected.\n\nWhat it is: CVE-2015-10113 is a low-severity vulnerability in WooFramework Tweaks Plugin, published on 5 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2015-10113 in the wild and no public exploit code.\n\nAffected product: WooFramework Tweaks Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-10113/ (Markdown: https://insights.sbomify.com/CVE-2015-10113/index.md)","id":"CVE-2015-10113","markdown":"https://insights.sbomify.com/CVE-2015-10113/index.md","name":"CVE-2015-10113","record":{"aliases":["GHSA-jhfr-w52p-37qv"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"An attacker can redirect users to malicious sites via the admin screen logic in the WooFramework Tweaks Plugin for WordPress.","user_interaction":"required","vuln_class":"open_redirect"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"wooframework_tweaks","vendor":"woocommerce"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-601","name":"URL Redirection to Untrusted Site"}],"description":"A vulnerability classified as problematic was found in WooFramework Tweaks Plugin up to 1.0.1 on WordPress. Affected by this vulnerability is the function admin_screen_logic of the file wooframework-tweaks.php. The manipulation of the argument url leads to open redirect. The attack can be launched remotely. Upgrading to version 1.0.2 is able to address this issue. The identifier of the patch is 3b57d405149c1a59d1119da6e0bb8212732c9c88. It is recommended to upgrade the affected component. The identifier VDB-230653 was assigned to this vulnerability.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"WooFramework Tweaks Plugin wooframework-tweaks.php admin_screen_logic redirect","id":"CVE-2015-10113","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"open_redirect","year":"2015"},"n_packages":0,"n_references":3,"next":{"headline":"WooSidebars Plugin class-woo-sidebars.php enable_custom_post_sidebars redirect","id":"CVE-2015-10114"},"packages":[],"prev":{"headline":"WooFramework Branding Plugin wooframework-branding.php admin_screen_logic redirect","id":"CVE-2015-10112"},"products":["WooFramework Tweaks Plugin"],"published":"2023-06-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"An attacker can redirect users to malicious sites via the admin screen logic in the WooFramework Tweaks Plugin for WordPress.","url":"https://insights.sbomify.com/CVE-2015-10113/"}