CVE-2015-10114 WooSidebars Plugin class-woo-sidebars.php enable_custom_post_sidebars redirect

Medium 4.3 Published Updated

An attacker can redirect users to malicious sites via the sendback parameter in the WooSidebars WordPress plugin.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2015-10114?

CVE-2015-10114 is a medium-severity vulnerability in WooSidebars Plugin, published on 5 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

A vulnerability, which was classified as problematic, has been found in WooSidebars Plugin up to 1.4.1 on WordPress. Affected by this issue is the function enable_custom_post_sidebars of the file classes/class-woo-sidebars.php. The manipulation of the argument sendback leads to open redirect. The attack may be launched remotely. Upgrading to version 1.4.2 is able to address this issue. The patch is identified as 1ac6d6ac26e185673f95fc1ccc56a392169ba601. It is recommended to upgrade the affected component. VDB-230654 is the identifier assigned to this vulnerability.

Weakness: CWE-601

Which versions are affected by CVE-2015-10114?

It affects 1 product.

Products include Woocommerce Woosidebars.

How do I fix CVE-2015-10114?

No fix has been published for CVE-2015-10114 yet. Limit exposure of the affected software until one is available.

Is CVE-2015-10114 being exploited?

There is no known exploitation of CVE-2015-10114 in the wild and no public exploit code.

Sources

Also known as GHSA-m2x7-w5hf-v68g.

Is CVE-2015-10114 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free