# CVE-2015-10114: WooSidebars Plugin class-woo-sidebars.php enable_custom_post_sidebars redirect

> An attacker can redirect users to malicious sites via the sendback parameter in the WooSidebars WordPress plugin.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 5 Jun 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-m2x7-w5hf-v68g

## What is CVE-2015-10114?

CVE-2015-10114 is a medium-severity vulnerability in WooSidebars Plugin, published on 5 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A vulnerability, which was classified as problematic, has been found in WooSidebars Plugin up to 1.4.1 on WordPress. Affected by this issue is the function enable_custom_post_sidebars of the file classes/class-woo-sidebars.php. The manipulation of the argument sendback leads to open redirect. The attack may be launched remotely. Upgrading to version 1.4.2 is able to address this issue. The patch is identified as 1ac6d6ac26e185673f95fc1ccc56a392169ba601. It is recommended to upgrade the affected component. VDB-230654 is the identifier assigned to this vulnerability.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2015-10114?

It affects 1 product.


Products: Woocommerce Woosidebars.

## How do I fix CVE-2015-10114?

No fix has been published for CVE-2015-10114 yet. Limit exposure of the affected software until one is available.

## Is CVE-2015-10114 being exploited?

There is no known exploitation of CVE-2015-10114 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-10114 and fix it if it is affected.

What it is: CVE-2015-10114 is a medium-severity vulnerability in WooSidebars Plugin, published on 5 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-10114 in the wild and no public exploit code.

Affected product: WooSidebars Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-10114/ (Markdown: https://insights.sbomify.com/CVE-2015-10114/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-10114
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-10114
- OSV: https://osv.dev/vulnerability/CVE-2015-10114

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-10114/
Summaries are generated and may contain mistakes; the official description above is the record.
