CVE-2015-10115 WooSidebars Sidebar Manager Converter Plugin class-woosidebars-sbm-converter.php process_request redirect

Medium 4.3 Published Updated

An attacker can redirect users to malicious sites via the WooSidebars Sidebar Manager Converter plugin's process_request function.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2015-10115?

CVE-2015-10115 is a medium-severity vulnerability in WooSidebars Sidebar Manager Converter Plugin, published on 5 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

A vulnerability, which was classified as problematic, was found in WooSidebars Sidebar Manager Converter Plugin up to 1.1.1 on WordPress. This affects the function process_request of the file classes/class-woosidebars-sbm-converter.php. The manipulation leads to open redirect. It is possible to initiate the attack remotely. Upgrading to version 1.1.2 is able to address this issue. The patch is named a0efb4ffb9dfe2925b889c1aa5ea40b4abbbda8a. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-230655.

Weakness: CWE-601

Which versions are affected by CVE-2015-10115?

It affects 1 product.

Products include Woocommerce Sidebar Manager to Woosidebars Converter.

How do I fix CVE-2015-10115?

No fix has been published for CVE-2015-10115 yet. Limit exposure of the affected software until one is available.

Is CVE-2015-10115 being exploited?

There is no known exploitation of CVE-2015-10115 in the wild and no public exploit code.

Sources

Also known as GHSA-jpmh-fxh8-hcqg.

Is CVE-2015-10115 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free