# CVE-2015-10115: WooSidebars Sidebar Manager Converter Plugin class-woosidebars-sbm-converter.php process_request redirect

> An attacker can redirect users to malicious sites via the WooSidebars Sidebar Manager Converter plugin's process_request function.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 5 Jun 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-jpmh-fxh8-hcqg

## What is CVE-2015-10115?

CVE-2015-10115 is a medium-severity vulnerability in WooSidebars Sidebar Manager Converter Plugin, published on 5 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A vulnerability, which was classified as problematic, was found in WooSidebars Sidebar Manager Converter Plugin up to 1.1.1 on WordPress. This affects the function process_request of the file classes/class-woosidebars-sbm-converter.php. The manipulation leads to open redirect. It is possible to initiate the attack remotely. Upgrading to version 1.1.2 is able to address this issue. The patch is named a0efb4ffb9dfe2925b889c1aa5ea40b4abbbda8a. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-230655.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2015-10115?

It affects 1 product.


Products: Woocommerce Sidebar Manager to Woosidebars Converter.

## How do I fix CVE-2015-10115?

No fix has been published for CVE-2015-10115 yet. Limit exposure of the affected software until one is available.

## Is CVE-2015-10115 being exploited?

There is no known exploitation of CVE-2015-10115 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-10115 and fix it if it is affected.

What it is: CVE-2015-10115 is a medium-severity vulnerability in WooSidebars Sidebar Manager Converter Plugin, published on 5 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-10115 in the wild and no public exploit code.

Affected product: WooSidebars Sidebar Manager Converter Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-10115/ (Markdown: https://insights.sbomify.com/CVE-2015-10115/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-10115
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-10115
- OSV: https://osv.dev/vulnerability/CVE-2015-10115

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-10115/
Summaries are generated and may contain mistakes; the official description above is the record.
