{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-10117 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2015-10117 yet. Limit exposure of the affected software until one is available.","what":"CVE-2015-10117 is a low-severity vulnerability in Gravity Forms DPS PxPay Plugin, published on 6 Jun 2023."},"fix_prompt":"Check this codebase for CVE-2015-10117 and fix it if it is affected.\n\nWhat it is: CVE-2015-10117 is a low-severity vulnerability in Gravity Forms DPS PxPay Plugin, published on 6 Jun 2023. \nExploitation: There is no known exploitation of CVE-2015-10117 in the wild and no public exploit code.\n\nAffected product: Gravity Forms DPS PxPay Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-10117/ (Markdown: https://insights.sbomify.com/CVE-2015-10117/index.md)","id":"CVE-2015-10117","markdown":"https://insights.sbomify.com/CVE-2015-10117/index.md","name":"CVE-2015-10117","record":{"aliases":["GHSA-xxhw-935w-672r"],"analysis":null,"analysis_generated_by":null,"assigner":"VulDB","cpe":[{"product":"gf_windcave_free","vendor":"webaware"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability, which was classified as problematic, was found in Gravity Forms DPS PxPay Plugin up to 1.4.2 on WordPress. Affected is an unknown function. The manipulation leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 1.4.3 is able to address this issue. The name of the patch is 5966a5e6343e3d5610bdfa126a5cfbae95e629b6. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-230664.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Gravity Forms DPS PxPay Plugin cross site scripting","id":"CVE-2015-10117","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":null,"year":"2015"},"n_packages":0,"n_references":4,"next":{"headline":"cchetanonline WP-CopyProtect wp-copyprotect.php CopyProtect_options_page cross site scripting","id":"CVE-2015-10118"},"packages":[],"prev":{"headline":"Cross-site request forgery in Favicon Plugin","id":"CVE-2015-10116"},"products":["Gravity Forms DPS PxPay Plugin"],"published":"2023-06-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2015-10117/"}