# CVE-2015-10117: Gravity Forms DPS PxPay Plugin cross site scripting


- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 6 Jun 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-xxhw-935w-672r

## What is CVE-2015-10117?

CVE-2015-10117 is a low-severity vulnerability in Gravity Forms DPS PxPay Plugin, published on 6 Jun 2023. 

### Official description

A vulnerability, which was classified as problematic, was found in Gravity Forms DPS PxPay Plugin up to 1.4.2 on WordPress. Affected is an unknown function. The manipulation leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 1.4.3 is able to address this issue. The name of the patch is 5966a5e6343e3d5610bdfa126a5cfbae95e629b6. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-230664.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2015-10117?

It affects 1 product.


Products: Webaware Gf Windcave Free.

## How do I fix CVE-2015-10117?

No fix has been published for CVE-2015-10117 yet. Limit exposure of the affected software until one is available.

## Is CVE-2015-10117 being exploited?

There is no known exploitation of CVE-2015-10117 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-10117 and fix it if it is affected.

What it is: CVE-2015-10117 is a low-severity vulnerability in Gravity Forms DPS PxPay Plugin, published on 6 Jun 2023. 
Exploitation: There is no known exploitation of CVE-2015-10117 in the wild and no public exploit code.

Affected product: Gravity Forms DPS PxPay Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-10117/ (Markdown: https://insights.sbomify.com/CVE-2015-10117/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-10117
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-10117
- OSV: https://osv.dev/vulnerability/CVE-2015-10117

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-10117/
Summaries are generated and may contain mistakes; the official description above is the record.
