{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-10118 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2015-10118 yet. Limit exposure of the affected software until one is available.","what":"CVE-2015-10118 is a low-severity cross-site scripting vulnerability in cchetanonline WP-CopyProtect, published on 12 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2015-10118 and fix it if it is affected.\n\nWhat it is: CVE-2015-10118 is a low-severity cross-site scripting vulnerability in cchetanonline WP-CopyProtect, published on 12 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2015-10118 in the wild and no public exploit code.\n\nAffected product: cchetanonline WP-CopyProtect. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-10118/ (Markdown: https://insights.sbomify.com/CVE-2015-10118/index.md)","id":"CVE-2015-10118","markdown":"https://insights.sbomify.com/CVE-2015-10118/index.md","name":"CVE-2015-10118","record":{"aliases":["GHSA-mrpc-qgx4-c5m2"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"An attacker can inject malicious scripts via the CopyProtect_nrc_text argument in the WP-CopyProtect plugin, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"wp-copyprotect","vendor":"wp-copyprotect_project"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability classified as problematic was found in cchetanonline WP-CopyProtect up to 3.0.0. This vulnerability affects the function CopyProtect_options_page of the file wp-copyprotect.php. The manipulation of the argument CopyProtect_nrc_text leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 3.1.0 is able to address this issue. The patch is identified as 8b8fe4102886b326330dc1ff06b17313fb10aee5. It is recommended to upgrade the affected component. VDB-231202 is the identifier assigned to this vulnerability.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"cchetanonline WP-CopyProtect wp-copyprotect.php CopyProtect_options_page cross site scripting","id":"CVE-2015-10118","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2015"},"n_packages":0,"n_references":3,"next":{"headline":"View All Posts Page Plugin view-all-posts-pages.php action_admin_notices_activation cross site scripting","id":"CVE-2015-10119"},"packages":[],"prev":{"headline":"Gravity Forms DPS PxPay Plugin cross site scripting","id":"CVE-2015-10117"},"products":["WP-CopyProtect"],"published":"2023-06-12","related":[{"cvss_score":4.3,"headline":"WordPress WP-CopyProtect [Protect your blog posts] Plugin \u003c= 3.1.0 is vulnerable to Cross Site Request Forgery (CSRF)","id":"CVE-2023-37995","kev_date_added":null,"published":"2023-10-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-06","vendors":["cchetanonline"]},"summary":"An attacker can inject malicious scripts via the CopyProtect_nrc_text argument in the WP-CopyProtect plugin, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2015-10118/"}