# CVE-2015-10118: cchetanonline WP-CopyProtect wp-copyprotect.php CopyProtect_options_page cross site scripting

> An attacker can inject malicious scripts via the CopyProtect_nrc_text argument in the WP-CopyProtect plugin, potentially compromising user sessions.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 12 Jun 2023
- **Updated:** 6 Jan 2025
- **Also known as:** GHSA-mrpc-qgx4-c5m2

## What is CVE-2015-10118?

CVE-2015-10118 is a low-severity cross-site scripting vulnerability in cchetanonline WP-CopyProtect, published on 12 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability classified as problematic was found in cchetanonline WP-CopyProtect up to 3.0.0. This vulnerability affects the function CopyProtect_options_page of the file wp-copyprotect.php. The manipulation of the argument CopyProtect_nrc_text leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 3.1.0 is able to address this issue. The patch is identified as 8b8fe4102886b326330dc1ff06b17313fb10aee5. It is recommended to upgrade the affected component. VDB-231202 is the identifier assigned to this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2015-10118?

It affects 1 product.


Products: Wp-Copyprotect Project Wp-Copyprotect.

## How do I fix CVE-2015-10118?

No fix has been published for CVE-2015-10118 yet. Limit exposure of the affected software until one is available.

## Is CVE-2015-10118 being exploited?

There is no known exploitation of CVE-2015-10118 in the wild and no public exploit code.

## Other vulnerabilities in cchetanonline WP-CopyProtect

- [CVE-2023-37995](https://insights.sbomify.com/CVE-2023-37995/): WordPress WP-CopyProtect [Protect your blog posts] Plugin <= 3.1.0 is vulnerable to Cross Site Request Forgery (CSRF) (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-10118 and fix it if it is affected.

What it is: CVE-2015-10118 is a low-severity cross-site scripting vulnerability in cchetanonline WP-CopyProtect, published on 12 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-10118 in the wild and no public exploit code.

Affected product: cchetanonline WP-CopyProtect. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-10118/ (Markdown: https://insights.sbomify.com/CVE-2015-10118/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-10118
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-10118
- OSV: https://osv.dev/vulnerability/CVE-2015-10118

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-10118/
Summaries are generated and may contain mistakes; the official description above is the record.
