{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-10119 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2015-10119 yet. Limit exposure of the affected software until one is available.","what":"CVE-2015-10119 is a low-severity cross-site scripting vulnerability in View All Posts Page Plugin, published on 10 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2015-10119 and fix it if it is affected.\n\nWhat it is: CVE-2015-10119 is a low-severity cross-site scripting vulnerability in View All Posts Page Plugin, published on 10 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2015-10119 in the wild and no public exploit code.\n\nAffected product: View All Posts Page Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-10119/ (Markdown: https://insights.sbomify.com/CVE-2015-10119/index.md)","id":"CVE-2015-10119","markdown":"https://insights.sbomify.com/CVE-2015-10119/index.md","name":"CVE-2015-10119","record":{"aliases":["GHSA-vq7j-qx4g-8wh5"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"A cross-site scripting vulnerability in the View All Posts Page WordPress plugin allows remote attackers to inject malicious scripts via the activation notice function.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"view_all_post\\'s_pages","vendor":"oomphinc"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability, which was classified as problematic, has been found in View All Posts Page Plugin up to 0.9.0 on WordPress. This issue affects the function action_admin_notices_activation of the file view-all-posts-pages.php. The manipulation leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 0.9.1 is able to address this issue. The patch is named bf914f3a59063fa4df8fd4925ae18a5d852396d7. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-233363.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"View All Posts Page Plugin view-all-posts-pages.php action_admin_notices_activation cross site scripting","id":"CVE-2015-10119","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2015"},"n_packages":0,"n_references":3,"next":{"headline":"WDS Multisite Aggregate Plugin WDS_Multisite_Aggregate_Options.php update_options cross site scripting","id":"CVE-2015-10120"},"packages":[],"prev":{"headline":"cchetanonline WP-CopyProtect wp-copyprotect.php CopyProtect_options_page cross site scripting","id":"CVE-2015-10118"},"products":["View All Posts Page Plugin"],"published":"2023-07-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"A cross-site scripting vulnerability in the View All Posts Page WordPress plugin allows remote attackers to inject malicious scripts via the activation notice function.","url":"https://insights.sbomify.com/CVE-2015-10119/"}