# CVE-2015-10119: View All Posts Page Plugin view-all-posts-pages.php action_admin_notices_activation cross site scripting

> A cross-site scripting vulnerability in the View All Posts Page WordPress plugin allows remote attackers to inject malicious scripts via the activation notice function.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 10 Jul 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-vq7j-qx4g-8wh5

## What is CVE-2015-10119?

CVE-2015-10119 is a low-severity cross-site scripting vulnerability in View All Posts Page Plugin, published on 10 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability, which was classified as problematic, has been found in View All Posts Page Plugin up to 0.9.0 on WordPress. This issue affects the function action_admin_notices_activation of the file view-all-posts-pages.php. The manipulation leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 0.9.1 is able to address this issue. The patch is named bf914f3a59063fa4df8fd4925ae18a5d852396d7. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-233363.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2015-10119?

It affects 1 product.


Products: Oomphinc View All Post\'s Pages.

## How do I fix CVE-2015-10119?

No fix has been published for CVE-2015-10119 yet. Limit exposure of the affected software until one is available.

## Is CVE-2015-10119 being exploited?

There is no known exploitation of CVE-2015-10119 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-10119 and fix it if it is affected.

What it is: CVE-2015-10119 is a low-severity cross-site scripting vulnerability in View All Posts Page Plugin, published on 10 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-10119 in the wild and no public exploit code.

Affected product: View All Posts Page Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-10119/ (Markdown: https://insights.sbomify.com/CVE-2015-10119/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-10119
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-10119
- OSV: https://osv.dev/vulnerability/CVE-2015-10119

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-10119/
Summaries are generated and may contain mistakes; the official description above is the record.
