{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-10120 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2015-10120 yet. Limit exposure of the affected software until one is available.","what":"CVE-2015-10120 is a low-severity cross-site scripting vulnerability in WDS Multisite Aggregate Plugin, published on 10 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2015-10120 and fix it if it is affected.\n\nWhat it is: CVE-2015-10120 is a low-severity cross-site scripting vulnerability in WDS Multisite Aggregate Plugin, published on 10 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2015-10120 in the wild and no public exploit code.\n\nAffected product: WDS Multisite Aggregate Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-10120/ (Markdown: https://insights.sbomify.com/CVE-2015-10120/index.md)","id":"CVE-2015-10120","markdown":"https://insights.sbomify.com/CVE-2015-10120/index.md","name":"CVE-2015-10120","record":{"aliases":["GHSA-95jr-m2m4-mc9m"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"A cross-site scripting vulnerability in the WDS Multisite Aggregate Plugin allows remote attackers to inject malicious scripts via the update_options function.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"wds_multisite_aggregate","vendor":"webdevstudios"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability, which was classified as problematic, was found in WDS Multisite Aggregate Plugin up to 1.0.0 on WordPress. Affected is the function update_options of the file includes/WDS_Multisite_Aggregate_Options.php. The manipulation leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 1.0.1 is able to address this issue. The name of the patch is 49e0bbcb6ff70e561365d9e0d26426598f63ca12. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-233364.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"WDS Multisite Aggregate Plugin WDS_Multisite_Aggregate_Options.php update_options cross site scripting","id":"CVE-2015-10120","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2015"},"n_packages":0,"n_references":3,"next":{"headline":"Beeliked Microsite Plugin beelikedmicrosite.php embed_handler cross site scripting","id":"CVE-2015-10121"},"packages":[],"prev":{"headline":"View All Posts Page Plugin view-all-posts-pages.php action_admin_notices_activation cross site scripting","id":"CVE-2015-10119"},"products":["WDS Multisite Aggregate Plugin"],"published":"2023-07-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"A cross-site scripting vulnerability in the WDS Multisite Aggregate Plugin allows remote attackers to inject malicious scripts via the update_options function.","url":"https://insights.sbomify.com/CVE-2015-10120/"}