# CVE-2015-10120: WDS Multisite Aggregate Plugin WDS_Multisite_Aggregate_Options.php update_options cross site scripting

> A cross-site scripting vulnerability in the WDS Multisite Aggregate Plugin allows remote attackers to inject malicious scripts via the update_options function.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 10 Jul 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-95jr-m2m4-mc9m

## What is CVE-2015-10120?

CVE-2015-10120 is a low-severity cross-site scripting vulnerability in WDS Multisite Aggregate Plugin, published on 10 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability, which was classified as problematic, was found in WDS Multisite Aggregate Plugin up to 1.0.0 on WordPress. Affected is the function update_options of the file includes/WDS_Multisite_Aggregate_Options.php. The manipulation leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 1.0.1 is able to address this issue. The name of the patch is 49e0bbcb6ff70e561365d9e0d26426598f63ca12. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-233364.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2015-10120?

It affects 1 product.


Products: Webdevstudios Wds Multisite Aggregate.

## How do I fix CVE-2015-10120?

No fix has been published for CVE-2015-10120 yet. Limit exposure of the affected software until one is available.

## Is CVE-2015-10120 being exploited?

There is no known exploitation of CVE-2015-10120 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-10120 and fix it if it is affected.

What it is: CVE-2015-10120 is a low-severity cross-site scripting vulnerability in WDS Multisite Aggregate Plugin, published on 10 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-10120 in the wild and no public exploit code.

Affected product: WDS Multisite Aggregate Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-10120/ (Markdown: https://insights.sbomify.com/CVE-2015-10120/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-10120
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-10120
- OSV: https://osv.dev/vulnerability/CVE-2015-10120

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-10120/
Summaries are generated and may contain mistakes; the official description above is the record.
