{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-10121 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2015-10121 yet. Limit exposure of the affected software until one is available.","what":"CVE-2015-10121 is a low-severity vulnerability in Beeliked Microsite Plugin, published on 10 Jul 2023."},"fix_prompt":"Check this codebase for CVE-2015-10121 and fix it if it is affected.\n\nWhat it is: CVE-2015-10121 is a low-severity vulnerability in Beeliked Microsite Plugin, published on 10 Jul 2023. \nExploitation: There is no known exploitation of CVE-2015-10121 in the wild and no public exploit code.\n\nAffected product: Beeliked Microsite Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-10121/ (Markdown: https://insights.sbomify.com/CVE-2015-10121/index.md)","id":"CVE-2015-10121","markdown":"https://insights.sbomify.com/CVE-2015-10121/index.md","name":"CVE-2015-10121","record":{"aliases":["GHSA-w2pj-frh6-gjhp"],"analysis":null,"analysis_generated_by":null,"assigner":"VulDB","cpe":[{"product":"beeliked","vendor":"beeliked"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability has been found in Beeliked Microsite Plugin up to 1.0.1 on WordPress and classified as problematic. Affected by this vulnerability is the function embed_handler of the file beelikedmicrosite.php. The manipulation leads to cross site scripting. The attack can be launched remotely. Upgrading to version 1.0.2 is able to address this issue. The identifier of the patch is d23bafb5d05fb2636a2b78331f9d3fca152903dc. It is recommended to upgrade the affected component. The identifier VDB-233365 was assigned to this vulnerability.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Beeliked Microsite Plugin beelikedmicrosite.php embed_handler cross site scripting","id":"CVE-2015-10121","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":null,"year":"2015"},"n_packages":0,"n_references":3,"next":{"headline":"wp-donate Plugin donate-display.php sql injection","id":"CVE-2015-10122"},"packages":[],"prev":{"headline":"WDS Multisite Aggregate Plugin WDS_Multisite_Aggregate_Options.php update_options cross site scripting","id":"CVE-2015-10120"},"products":["Beeliked Microsite Plugin"],"published":"2023-07-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-21","vendors":["n/a"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2015-10121/"}