# CVE-2015-10121: Beeliked Microsite Plugin beelikedmicrosite.php embed_handler cross site scripting


- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 10 Jul 2023
- **Updated:** 21 Nov 2024
- **Also known as:** GHSA-w2pj-frh6-gjhp

## What is CVE-2015-10121?

CVE-2015-10121 is a low-severity vulnerability in Beeliked Microsite Plugin, published on 10 Jul 2023. 

### Official description

A vulnerability has been found in Beeliked Microsite Plugin up to 1.0.1 on WordPress and classified as problematic. Affected by this vulnerability is the function embed_handler of the file beelikedmicrosite.php. The manipulation leads to cross site scripting. The attack can be launched remotely. Upgrading to version 1.0.2 is able to address this issue. The identifier of the patch is d23bafb5d05fb2636a2b78331f9d3fca152903dc. It is recommended to upgrade the affected component. The identifier VDB-233365 was assigned to this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2015-10121?

It affects 1 product.


Products: Beeliked Beeliked.

## How do I fix CVE-2015-10121?

No fix has been published for CVE-2015-10121 yet. Limit exposure of the affected software until one is available.

## Is CVE-2015-10121 being exploited?

There is no known exploitation of CVE-2015-10121 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-10121 and fix it if it is affected.

What it is: CVE-2015-10121 is a low-severity vulnerability in Beeliked Microsite Plugin, published on 10 Jul 2023. 
Exploitation: There is no known exploitation of CVE-2015-10121 in the wild and no public exploit code.

Affected product: Beeliked Microsite Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-10121/ (Markdown: https://insights.sbomify.com/CVE-2015-10121/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-10121
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-10121
- OSV: https://osv.dev/vulnerability/CVE-2015-10121

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-10121/
Summaries are generated and may contain mistakes; the official description above is the record.
