# CVE-2015-10122: wp-donate Plugin donate-display.php sql injection

> Remote attackers can exploit SQL injection in the wp-donate plugin to read or modify database contents.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Jul 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-7f5v-v2f3-8m3w

## What is CVE-2015-10122?

CVE-2015-10122 is a medium-severity SQL injection vulnerability in wp-donate Plugin, published on 18 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was found in wp-donate Plugin up to 1.4 on WordPress. It has been classified as critical. This affects an unknown part of the file includes/donate-display.php. The manipulation leads to sql injection. It is possible to initiate the attack remotely. Upgrading to version 1.5 is able to address this issue. The identifier of the patch is 019114cb788d954c5d1b36d6c62418619e93a757. It is recommended to upgrade the affected component. The identifier VDB-234249 was assigned to this vulnerability.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2015-10122?

It affects 1 product.


Products: Wp Donate Project Wp Donate.

## How do I fix CVE-2015-10122?

No fix has been published for CVE-2015-10122 yet. Limit exposure of the affected software until one is available.

## Is CVE-2015-10122 being exploited?

There is no known exploitation of CVE-2015-10122 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-10122 and fix it if it is affected.

What it is: CVE-2015-10122 is a medium-severity SQL injection vulnerability in wp-donate Plugin, published on 18 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-10122 in the wild and no public exploit code.

Affected product: wp-donate Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-10122/ (Markdown: https://insights.sbomify.com/CVE-2015-10122/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-10122
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-10122
- OSV: https://osv.dev/vulnerability/CVE-2015-10122

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-10122/
Summaries are generated and may contain mistakes; the official description above is the record.
