CVE-2015-10124 Most Popular Posts Widget Plugin functions.php show_views sql injection

Medium 6.3 Published Updated

Remote attackers can exploit SQL injection in the Most Popular Posts Widget Plugin to read or modify database contents.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2015-10124?

CVE-2015-10124 is a medium-severity SQL injection vulnerability in Most Popular Posts Widget Plugin, published on 2 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerability was found in Most Popular Posts Widget Plugin up to 0.8 on WordPress. It has been classified as critical. Affected is the function add_views/show_views of the file functions.php. The manipulation leads to sql injection. It is possible to launch the attack remotely. Upgrading to version 0.9 is able to address this issue. The patch is identified as a99667d11ac8d320006909387b100e9a8b5c12e1. It is recommended to upgrade the affected component. VDB-241026 is the identifier assigned to this vulnerability.

Weakness: CWE-89

Which versions are affected by CVE-2015-10124?

It affects 1 product.

Products include Smartfan Most Popular Posts Widget.

How do I fix CVE-2015-10124?

No fix has been published for CVE-2015-10124 yet. Limit exposure of the affected software until one is available.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2015-10124 being exploited?

There is no known exploitation of CVE-2015-10124 in the wild and no public exploit code.

Sources

Also known as GHSA-8fpf-jxpx-6gf6.

Is CVE-2015-10124 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free