# CVE-2015-10125: WP Ultimate CSV Importer Plugin cross-site request forgery

> Attackers can trick authenticated users into performing unintended actions in the WP Ultimate CSV Importer Plugin via cross-site request forgery.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 5 Oct 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-v7hx-8qh9-xg29

## What is CVE-2015-10125?

CVE-2015-10125 is a medium-severity vulnerability in WP Ultimate CSV Importer Plugin, published on 5 Oct 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A vulnerability classified as problematic has been found in WP Ultimate CSV Importer Plugin 3.7.2 on WordPress. This affects an unknown part. The manipulation leads to cross-site request forgery. It is possible to initiate the attack remotely. Upgrading to version 3.7.3 is able to address this issue. The identifier of the patch is 13c30af721d3f989caac72dd0f56cf0dc40fad7e. It is recommended to upgrade the affected component. The identifier VDB-241317 was assigned to this vulnerability.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2015-10125?

It affects 1 product.


Products: Smackcoders Import All Pages\, Post Types\, Products\, Orders\, and Users as Xml \& Csv.

## How do I fix CVE-2015-10125?

No fix has been published for CVE-2015-10125 yet. Limit exposure of the affected software until one is available.

## Is CVE-2015-10125 being exploited?

There is no known exploitation of CVE-2015-10125 in the wild and no public exploit code.

## Other vulnerabilities in WP Ultimate CSV Importer Plugin

- [CVE-2018-20967](https://insights.sbomify.com/CVE-2018-20967/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2022-3243](https://insights.sbomify.com/CVE-2022-3243/): Import all XML, CSV & TXT into WordPress < 6.5.8 - Admin+ SQLi (high 7.2)
- [CVE-2022-1977](https://insights.sbomify.com/CVE-2022-1977/): WP Ultimate CSV Importer < 6.5.3 - Admin+ Blind SSRF (high 7.2)
- [CVE-2015-9306](https://insights.sbomify.com/CVE-2015-9306/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2022-0360](https://insights.sbomify.com/CVE-2022-0360/): WP Ultimate CSV Importer < 6.4.3 - Admin+ Stored Cross-Site Scripting (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-10125 and fix it if it is affected.

What it is: CVE-2015-10125 is a medium-severity vulnerability in WP Ultimate CSV Importer Plugin, published on 5 Oct 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-10125 in the wild and no public exploit code.

Affected product: WP Ultimate CSV Importer Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-10125/ (Markdown: https://insights.sbomify.com/CVE-2015-10125/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-10125
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-10125
- OSV: https://osv.dev/vulnerability/CVE-2015-10125

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-10125/
Summaries are generated and may contain mistakes; the official description above is the record.
