# CVE-2015-10128: rt-prettyphoto Plugin rt-prettyphoto.php royal_prettyphoto_plugin_links cross site scripting


- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 2 Jan 2024
- **Updated:** 17 Apr 2025
- **Also known as:** GHSA-jx85-225x-qv99

## What is CVE-2015-10128?

CVE-2015-10128 is a low-severity vulnerability in rt-prettyphoto Plugin, published on 2 Jan 2024. 

### Official description

A vulnerability was found in rt-prettyphoto Plugin up to 1.2 on WordPress and classified as problematic. Affected by this issue is the function royal_prettyphoto_plugin_links of the file rt-prettyphoto.php. The manipulation leads to cross site scripting. The attack may be launched remotely. Upgrading to version 1.3 is able to address this issue. The patch is identified as 0d3d38cfa487481b66869e4212df1cefc281ecb7. It is recommended to upgrade the affected component. VDB-249422 is the identifier assigned to this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2015-10128?

It affects 1 product.


Products: Royaltechbd Royal Prettyphoto.

## How do I fix CVE-2015-10128?

No fix has been published for CVE-2015-10128 yet. Limit exposure of the affected software until one is available.

## Is CVE-2015-10128 being exploited?

There is no known exploitation of CVE-2015-10128 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-10128 and fix it if it is affected.

What it is: CVE-2015-10128 is a low-severity vulnerability in rt-prettyphoto Plugin, published on 2 Jan 2024. 
Exploitation: There is no known exploitation of CVE-2015-10128 in the wild and no public exploit code.

Affected product: rt-prettyphoto Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-10128/ (Markdown: https://insights.sbomify.com/CVE-2015-10128/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-10128
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-10128
- OSV: https://osv.dev/vulnerability/CVE-2015-10128

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-10128/
Summaries are generated and may contain mistakes; the official description above is the record.
