{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2015-10131 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2015-10131 yet. Limit exposure of the affected software until one is available.","what":"CVE-2015-10131 is a low-severity cross-site scripting vulnerability in chrisy TFO Graphviz Plugin, published on 31 Mar 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2015-10131 and fix it if it is affected.\n\nWhat it is: CVE-2015-10131 is a low-severity cross-site scripting vulnerability in chrisy TFO Graphviz Plugin, published on 31 Mar 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2015-10131 in the wild and no public exploit code.\n\nAffected product: chrisy TFO Graphviz Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-10131/ (Markdown: https://insights.sbomify.com/CVE-2015-10131/index.md)","id":"CVE-2015-10131","markdown":"https://insights.sbomify.com/CVE-2015-10131/index.md","name":"CVE-2015-10131","record":{"aliases":["GHSA-p33p-wj85-4vjp"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"An attacker can inject malicious scripts into the admin page of the TFO Graphviz WordPress plugin, potentially compromising administrator sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability was found in chrisy TFO Graphviz Plugin up to 1.9 on WordPress and classified as problematic. Affected by this issue is the function admin_page_load/admin_page of the file tfo-graphviz-admin.php. The manipulation leads to cross site scripting. The attack may be launched remotely. Upgrading to version 1.10 is able to address this issue. The name of the patch is 594c953a345f79e26003772093b0caafc14b92c2. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-258620.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"chrisy TFO Graphviz Plugin tfo-graphviz-admin.php admin_page cross site scripting","id":"CVE-2015-10131","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2015"},"n_packages":0,"n_references":4,"next":{"headline":"Thimo Grauerholz WP-Spreadplugin spreadplugin.php cross site scripting","id":"CVE-2015-10132"},"packages":[],"prev":{"headline":"Cross-site request forgery in Team Circle Image Slider With Lightbox","id":"CVE-2015-10130"},"products":["TFO Graphviz Plugin"],"published":"2024-03-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-06","vendors":["chrisy"]},"summary":"An attacker can inject malicious scripts into the admin page of the TFO Graphviz WordPress plugin, potentially compromising administrator sessions.","url":"https://insights.sbomify.com/CVE-2015-10131/"}