# CVE-2015-10131: chrisy TFO Graphviz Plugin tfo-graphviz-admin.php admin_page cross site scripting

> An attacker can inject malicious scripts into the admin page of the TFO Graphviz WordPress plugin, potentially compromising administrator sessions.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 31 Mar 2024
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-p33p-wj85-4vjp

## What is CVE-2015-10131?

CVE-2015-10131 is a low-severity cross-site scripting vulnerability in chrisy TFO Graphviz Plugin, published on 31 Mar 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability was found in chrisy TFO Graphviz Plugin up to 1.9 on WordPress and classified as problematic. Affected by this issue is the function admin_page_load/admin_page of the file tfo-graphviz-admin.php. The manipulation leads to cross site scripting. The attack may be launched remotely. Upgrading to version 1.10 is able to address this issue. The name of the patch is 594c953a345f79e26003772093b0caafc14b92c2. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-258620.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2015-10131?


## How do I fix CVE-2015-10131?

No fix has been published for CVE-2015-10131 yet. Limit exposure of the affected software until one is available.

## Is CVE-2015-10131 being exploited?

There is no known exploitation of CVE-2015-10131 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-10131 and fix it if it is affected.

What it is: CVE-2015-10131 is a low-severity cross-site scripting vulnerability in chrisy TFO Graphviz Plugin, published on 31 Mar 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-10131 in the wild and no public exploit code.

Affected product: chrisy TFO Graphviz Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-10131/ (Markdown: https://insights.sbomify.com/CVE-2015-10131/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-10131
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-10131
- OSV: https://osv.dev/vulnerability/CVE-2015-10131

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-10131/
Summaries are generated and may contain mistakes; the official description above is the record.
