CVE-2015-10132 Thimo Grauerholz WP-Spreadplugin spreadplugin.php cross site scripting

Low 3.5 Published Updated

A cross-site scripting vulnerability in the WP-Spreadplugin allows remote attackers to inject malicious scripts via the Spreadplugin argument.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2015-10132?

CVE-2015-10132 is a low-severity cross-site scripting vulnerability in Thimo Grauerholz WP-Spreadplugin, published on 21 Apr 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A vulnerability classified as problematic was found in Thimo Grauerholz WP-Spreadplugin up to 3.8.6.1 on WordPress. This vulnerability affects unknown code of the file spreadplugin.php. The manipulation of the argument Spreadplugin leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 3.8.6.6 is able to address this issue. The name of the patch is a9b9afc641854698e80aa5dd9ababfc8e0e57d69. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-261676.

Weakness: CWE-79

Which versions are affected by CVE-2015-10132?

How do I fix CVE-2015-10132?

No fix has been published for CVE-2015-10132 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2015-10132 being exploited?

There is no known exploitation of CVE-2015-10132 in the wild and no public exploit code.

Sources

Also known as GHSA-3hc3-wpjg-9xgr.

Is CVE-2015-10132 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free