{"answers":{"affected":"4 open source packages ship an affected version, including serve-static. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-1164 in the wild and no public exploit code.","fix":"Upgrade serve-static to 1.7.2 or later.","what":"CVE-2015-1164 is a medium-severity vulnerability in n/a, published on 21 Jan 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2015-1164 and fix it if it is affected.\n\nWhat it is: CVE-2015-1164 is a medium-severity vulnerability in n/a, published on 21 Jan 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2015-1164 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- serve-static (npm): affected all versions; fixed in 1.7.2\n- serve-static (npm): affected all versions; fixed in 1.7.2\n- serve-static (npm): affected from 1.7.0; fixed in 1.7.2\n- serve-static (npm): affected from 1.7.0; fixed in 1.7.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-1164/ (Markdown: https://insights.sbomify.com/CVE-2015-1164/index.md)","id":"CVE-2015-1164","markdown":"https://insights.sbomify.com/CVE-2015-1164/index.md","name":"CVE-2015-1164","record":{"aliases":["AZL-45312","DEBIAN-CVE-2015-1164","GHSA-c3x7-gjmx-r2ff"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js static file plugin","requires_auth":"none","summary":"Remote attackers can redirect users to malicious sites via crafted URLs in the serve-static plugin, facilitating phishing attacks.","user_interaction":"required","vuln_class":"open_redirect"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"serve-static","vendor":"serve-static_project"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[],"description":"Open redirect vulnerability in the serve-static plugin before 1.7.2 for Node.js, when mounted at the root, allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via a // (slash slash) followed by a domain in the PATH_INFO to the default URI.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Open Redirect in serve-static","id":"CVE-2015-1164","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"open_redirect","year":"2015"},"n_packages":4,"n_references":5,"next":{"headline":"Information disclosure in n/a","id":"CVE-2015-1165"},"packages":[{"ecosystem":"npm","fixed":["1.7.2"],"introduced":["0"],"last_affected":[],"package":"serve-static","purl":null,"source":"GHSA-c3x7-gjmx-r2ff"},{"ecosystem":"npm","fixed":["1.7.2"],"introduced":["0"],"last_affected":[],"package":"serve-static","purl":"pkg:npm/serve-static","source":"GHSA-c3x7-gjmx-r2ff"},{"ecosystem":"npm","fixed":["1.7.2"],"introduced":["1.7.0"],"last_affected":[],"package":"serve-static","purl":null,"source":"GHSA-c3x7-gjmx-r2ff"},{"ecosystem":"npm","fixed":["1.7.2"],"introduced":["1.7.0"],"last_affected":[],"package":"serve-static","purl":"pkg:npm/serve-static","source":"GHSA-c3x7-gjmx-r2ff"}],"prev":{"headline":"This candidate is unused by its CNA.","id":"CVE-2015-1160"},"products":["n/a"],"published":"2015-01-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can redirect users to malicious sites via crafted URLs in the serve-static plugin, facilitating phishing attacks.","url":"https://insights.sbomify.com/CVE-2015-1164/"}