# CVE-2015-1164: Open Redirect in serve-static

> Remote attackers can redirect users to malicious sites via crafted URLs in the serve-static plugin, facilitating phishing attacks.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Jan 2015
- **Updated:** 6 Aug 2024
- **Also known as:** AZL-45312, DEBIAN-CVE-2015-1164, GHSA-c3x7-gjmx-r2ff

## What is CVE-2015-1164?

CVE-2015-1164 is a medium-severity vulnerability in n/a, published on 21 Jan 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Open redirect vulnerability in the serve-static plugin before 1.7.2 for Node.js, when mounted at the root, allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via a // (slash slash) followed by a domain in the PATH_INFO to the default URI.

## Which versions are affected by CVE-2015-1164?

4 open source packages ship an affected version, including serve-static. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `serve-static` | npm | All versions | 1.7.2 |
| `serve-static` | npm | All versions | 1.7.2 |
| `serve-static` | npm | From 1.7.0 | 1.7.2 |
| `serve-static` | npm | From 1.7.0 | 1.7.2 |

Products: Serve-Static Project Serve-Static.

## How do I fix CVE-2015-1164?

Upgrade serve-static to 1.7.2 or later.

## Is CVE-2015-1164 being exploited?

There is no known exploitation of CVE-2015-1164 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-1164 and fix it if it is affected.

What it is: CVE-2015-1164 is a medium-severity vulnerability in n/a, published on 21 Jan 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-1164 in the wild and no public exploit code.

Affected packages and fixed versions:
- serve-static (npm): affected all versions; fixed in 1.7.2
- serve-static (npm): affected all versions; fixed in 1.7.2
- serve-static (npm): affected from 1.7.0; fixed in 1.7.2
- serve-static (npm): affected from 1.7.0; fixed in 1.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-1164/ (Markdown: https://insights.sbomify.com/CVE-2015-1164/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-1164
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-1164
- OSV: https://osv.dev/vulnerability/CVE-2015-1164

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-1164/
Summaries are generated and may contain mistakes; the official description above is the record.
