# CVE-2015-1340: chmod race in doUidshiftIntoContainer

> A race condition in LXD allows attackers to change file permissions on the host system via symbolic links, potentially leading to privilege escalation.

- **Severity:** High 7.0 (`CVSS:3.0/AV:P/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Apr 2019
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-8mpq-fmr3-6jxv, GO-2021-0071

## What is CVE-2015-1340?

CVE-2015-1340 is a high-severity vulnerability in Ubuntu LXD, published on 22 Apr 2019. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

LXD before version 0.19-0ubuntu5 doUidshiftIntoContainer() has an unsafe Chmod() call that races against the stat in the Filepath.Walk() function. A symbolic link created in that window could cause any file on the system to have any mode of the attacker's choice.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2015-1340?

3 open source packages ship an affected version, including github.com/lxc/lxd. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/lxc/lxd` | Go | All versions | 0.0.0-20151004155856-19c6961cc101 |
| `github.com/lxc/lxd` | Go | All versions | 0.0.0-20151004155856-19c6961cc101 |
| `github.com/lxc/lxd` | Go | All versions | 0.0.0-20151004155856-19c6961cc101 |

Products: Linuxcontainers Lxd.

## How do I fix CVE-2015-1340?

Upgrade github.com/lxc/lxd to 0.0.0-20151004155856-19c6961cc101 or later.

## Is CVE-2015-1340 being exploited?

There is no known exploitation of CVE-2015-1340 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-1340 and fix it if it is affected.

What it is: CVE-2015-1340 is a high-severity vulnerability in Ubuntu LXD, published on 22 Apr 2019. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-1340 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/lxc/lxd (Go): affected all versions; fixed in 0.0.0-20151004155856-19c6961cc101
- github.com/lxc/lxd (Go): affected all versions; fixed in 0.0.0-20151004155856-19c6961cc101
- github.com/lxc/lxd (Go): affected all versions; fixed in 0.0.0-20151004155856-19c6961cc101

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-1340/ (Markdown: https://insights.sbomify.com/CVE-2015-1340/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-1340
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-1340
- OSV: https://osv.dev/vulnerability/CVE-2015-1340

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-1340/
Summaries are generated and may contain mistakes; the official description above is the record.
