{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2015-1345 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2015-1345 is a low-severity denial of service vulnerability in Opensuse Opensuse, published on 12 Feb 2015. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2015-1345 and fix it if it is affected.\n\nWhat it is: CVE-2015-1345 is a low-severity denial of service vulnerability in Opensuse Opensuse, published on 12 Feb 2015. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2015-1345 in the wild and no public exploit code.\n\nAffected product: Opensuse Opensuse. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-1345/ (Markdown: https://insights.sbomify.com/CVE-2015-1345/index.md)","id":"CVE-2015-1345","markdown":"https://insights.sbomify.com/CVE-2015-1345/index.md","name":"CVE-2015-1345","record":{"aliases":["DEBIAN-CVE-2015-1345","GHSA-5wcr-xg97-jwqq","RHSA-2015:2111","openSUSE-SU-2024:10248-1"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"GNU grep utility","requires_auth":"none","summary":"Local attackers can crash the grep utility via crafted input using the -F option, causing a denial of service.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"grep","vendor":"gnu"},{"product":"opensuse","vendor":"opensuse"}],"cvss":{"score":2.1,"severity":"low","source":"nvd","vector":"AV:L/AC:L/Au:N/C:N/I:N/A:P","version":"2.0"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"The bmexec_trans function in kwset.c in grep 2.19 through 2.21 allows local users to cause a denial of service (out-of-bounds heap read and crash) via crafted input when using the -F option.","ecosystems":["Red Hat:enterprise_linux:7::client","Red Hat:enterprise_linux:7::computenode","Red Hat:enterprise_linux:7::server","Red Hat:enterprise_linux:7::workstation","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2015-1345","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"opensuse:opensuse","products":["opensuse:opensuse"],"type":"denial_of_service","year":"2015"},"n_packages":9,"n_references":7,"next":{"headline":"Denial of service in n/a","id":"CVE-2015-1346"},"packages":[{"ecosystem":"Red Hat:enterprise_linux:7::client","fixed":["0:2.20-2.el7"],"introduced":["0"],"last_affected":[],"package":"grep","purl":"pkg:rpm/redhat/grep","source":"RHSA-2015:2111"},{"ecosystem":"Red Hat:enterprise_linux:7::client","fixed":["0:2.20-2.el7"],"introduced":["0"],"last_affected":[],"package":"grep-debuginfo","purl":"pkg:rpm/redhat/grep-debuginfo","source":"RHSA-2015:2111"},{"ecosystem":"Red Hat:enterprise_linux:7::computenode","fixed":["0:2.20-2.el7"],"introduced":["0"],"last_affected":[],"package":"grep","purl":"pkg:rpm/redhat/grep","source":"RHSA-2015:2111"},{"ecosystem":"Red Hat:enterprise_linux:7::computenode","fixed":["0:2.20-2.el7"],"introduced":["0"],"last_affected":[],"package":"grep-debuginfo","purl":"pkg:rpm/redhat/grep-debuginfo","source":"RHSA-2015:2111"},{"ecosystem":"Red Hat:enterprise_linux:7::server","fixed":["0:2.20-2.el7"],"introduced":["0"],"last_affected":[],"package":"grep","purl":"pkg:rpm/redhat/grep","source":"RHSA-2015:2111"},{"ecosystem":"Red Hat:enterprise_linux:7::server","fixed":["0:2.20-2.el7"],"introduced":["0"],"last_affected":[],"package":"grep-debuginfo","purl":"pkg:rpm/redhat/grep-debuginfo","source":"RHSA-2015:2111"},{"ecosystem":"Red Hat:enterprise_linux:7::workstation","fixed":["0:2.20-2.el7"],"introduced":["0"],"last_affected":[],"package":"grep","purl":"pkg:rpm/redhat/grep","source":"RHSA-2015:2111"},{"ecosystem":"Red Hat:enterprise_linux:7::workstation","fixed":["0:2.20-2.el7"],"introduced":["0"],"last_affected":[],"package":"grep-debuginfo","purl":"pkg:rpm/redhat/grep-debuginfo","source":"RHSA-2015:2111"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.27-2.1"],"introduced":["0"],"last_affected":[],"package":"grep","purl":"pkg:rpm/opensuse/grep\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10248-1"}],"prev":{"headline":"Privilege escalation in n/a","id":"CVE-2015-1344"},"products":["n/a"],"published":"2015-02-12","related":[{"cvss_score":4.4,"headline":"Integer overflow in n/a","id":"CVE-2012-5667","kev_date_added":null,"published":"2013-01-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Local attackers can crash the grep utility via crafted input using the -F option, causing a denial of service.","url":"https://insights.sbomify.com/CVE-2015-1345/"}