# CVE-2015-1370: VBScript Content Injection in marked

> Remote attackers can execute arbitrary scripts in user browsers via XSS in the marked Node.js library using vbscript tags.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Jan 2015
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-1370, GHSA-cfjh-p3g4-3q2f, UBUNTU-CVE-2015-1370

## What is CVE-2015-1370?

CVE-2015-1370 is a medium-severity cross-site scripting vulnerability in n/a, published on 27 Jan 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Incomplete blacklist vulnerability in marked 0.3.2 and earlier for Node.js allows remote attackers to conduct cross-site scripting (XSS) attacks via a vbscript tag in a link.

## Which versions are affected by CVE-2015-1370?

2 open source packages ship an affected version, including marked. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `marked` | npm | All versions | 0.3.3 |
| `marked` | npm | All versions | 0.3.3 |

Products: Marked Project Marked.

## How do I fix CVE-2015-1370?

Upgrade marked to 0.3.3 or later.

## Is CVE-2015-1370 being exploited?

There is no known exploitation of CVE-2015-1370 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-41680](https://insights.sbomify.com/CVE-2026-41680/): Marked: OOM Denial of Service via Infinite Recursion in marked Tokenizer (high 8.7)
- [CVE-2017-16114](https://insights.sbomify.com/CVE-2017-16114/): Regular Expression Denial of Service in marked (high 7.5)
- [CVE-2018-25110](https://insights.sbomify.com/CVE-2018-25110/): Regular Expression Denial of Service (ReDoS) in markedjs/marked (medium 6.9)
- [CVE-2014-3743](https://insights.sbomify.com/CVE-2014-3743/): Multiple Content Injection Vulnerabilities in marked (medium 6.1)
- [CVE-2016-10531](https://insights.sbomify.com/CVE-2016-10531/): Sanitization bypass using HTML Entities in marked (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-1370 and fix it if it is affected.

What it is: CVE-2015-1370 is a medium-severity cross-site scripting vulnerability in n/a, published on 27 Jan 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-1370 in the wild and no public exploit code.

Affected packages and fixed versions:
- marked (npm): affected all versions; fixed in 0.3.3
- marked (npm): affected all versions; fixed in 0.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-1370/ (Markdown: https://insights.sbomify.com/CVE-2015-1370/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-1370
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-1370
- OSV: https://osv.dev/vulnerability/CVE-2015-1370

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-1370/
Summaries are generated and may contain mistakes; the official description above is the record.
