{"answers":{"affected":"It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-1419 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2015-1419 is a medium-severity authentication bypass vulnerability in Opensuse Opensuse, published on 28 Jan 2015. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-1419 and fix it if it is affected.\n\nWhat it is: CVE-2015-1419 is a medium-severity authentication bypass vulnerability in Opensuse Opensuse, published on 28 Jan 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-1419 exists.\n\nAffected product: Opensuse Opensuse. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-1419/ (Markdown: https://insights.sbomify.com/CVE-2015-1419/index.md)","id":"CVE-2015-1419","markdown":"https://insights.sbomify.com/CVE-2015-1419/index.md","name":"CVE-2015-1419","record":{"aliases":["DEBIAN-CVE-2015-1419","GHSA-2r24-78wj-92qx","MGASA-2015-0103","SUSE-RU-2015:0952-1","SUSE-SU-2015:0417-1","SUSE-SU-2015:0516-1","UBUNTU-CVE-2015-1419","openSUSE-SU-2024:10264-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"vsftpd FTP server","requires_auth":"none","summary":"Remote attackers can bypass access restrictions in vsftpd due to improper deny_file parsing, allowing unauthorized access to protected resources.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"opensuse","vendor":"opensuse"},{"product":"vsftpd","vendor":"vsftpd_project"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[],"description":"Unspecified vulnerability in vsftpd 3.0.2 and earlier allows remote attackers to bypass access restrictions via unknown vectors, related to deny_file parsing.","ecosystems":["SUSE:Linux Enterprise Server 12","SUSE:Linux Enterprise Server for SAP Applications 12","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":null,"kind":"nuclei","ref":"network/cves/2015/CVE-2015-1419.yaml","stars":null,"title":"vsftpd \u003c= 3.0.2 - Access Restriction Bypass"}],"tier":"weaponised"},"has_fix":true,"headline":"Auth bypass in n/a","id":"CVE-2015-1419","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"opensuse:opensuse","products":["opensuse:opensuse"],"type":"auth_bypass","year":"2015"},"n_packages":3,"n_references":3,"next":{"headline":"Race condition in n/a","id":"CVE-2015-1420"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Server 12","fixed":["3.0.2-18.1"],"introduced":["0"],"last_affected":[],"package":"vsftpd","purl":"pkg:rpm/suse/vsftpd\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012","source":"SUSE-SU-2015:0516-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12","fixed":["3.0.2-18.1"],"introduced":["0"],"last_affected":[],"package":"vsftpd","purl":"pkg:rpm/suse/vsftpd\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012","source":"SUSE-SU-2015:0516-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["3.0.3-7.1"],"introduced":["0"],"last_affected":[],"package":"vsftpd","purl":"pkg:rpm/opensuse/vsftpd\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10264-1"}],"prev":{"headline":"Command injection in n/a","id":"CVE-2015-1418"},"products":["n/a"],"published":"2015-01-28","related":[{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2015-5957","kev_date_added":null,"published":"2015-09-28"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2015-0491","kev_date_added":null,"published":"2015-04-16"},{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2008-2388","kev_date_added":null,"published":"2008-06-06"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2010-1866","kev_date_added":null,"published":"2010-05-07"},{"cvss_score":9.3,"headline":"Other in n/a","id":"CVE-2015-0492","kev_date_added":null,"published":"2015-04-16"},{"cvss_score":8.8,"headline":"Memory corruption in n/a","id":"CVE-2014-0158","kev_date_added":null,"published":"2018-04-10"},{"cvss_score":8.8,"headline":"Null dereference in n/a","id":"CVE-2016-4343","kev_date_added":null,"published":"2016-05-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can bypass access restrictions in vsftpd due to improper deny_file parsing, allowing unauthorized access to protected resources.","url":"https://insights.sbomify.com/CVE-2015-1419/"}