{"answers":{"affected":"2 open source packages ship an affected version, including facter. It affects 2 products.","exploited":"There is no known exploitation of CVE-2015-1426 in the wild and no public exploit code.","fix":"Upgrade facter to 2.4.1 or later.","what":"CVE-2015-1426 is a low-severity vulnerability in n/a, published on 23 Feb 2015. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-1426 and fix it if it is affected.\n\nWhat it is: CVE-2015-1426 is a low-severity vulnerability in n/a, published on 23 Feb 2015. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-1426 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- facter (RubyGems): affected from 1.6.0; fixed in 2.4.1\n- facter (RubyGems): affected from 1.6.0; fixed in 2.4.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-1426/ (Markdown: https://insights.sbomify.com/CVE-2015-1426/index.md)","id":"CVE-2015-1426","markdown":"https://insights.sbomify.com/CVE-2015-1426/index.md","name":"CVE-2015-1426","record":{"aliases":["DEBIAN-CVE-2015-1426","GHSA-j436-h7hm-rx46","UBUNTU-CVE-2015-1426"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Puppet Facter library","requires_auth":"none","summary":"Local attackers can read sensitive Amazon EC2 IAM instance metadata via Puppet Facter, exposing credentials and configuration data.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"facter","vendor":"puppet"},{"product":"facter","vendor":"puppetlabs"}],"cvss":{"score":2.1,"severity":"low","source":"nvd","vector":"AV:L/AC:L/Au:N/C:P/I:N/A:N","version":"2.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Puppet Labs Facter 1.6.0 through 2.4.0 allows local users to obtains sensitive Amazon EC2 IAM instance metadata by reading a fact for an Amazon EC2 node.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Puppet Labs Facter allows local users to obtain sensitive Amazon EC2 IAM instance metadata","id":"CVE-2015-1426","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"information_disclosure","year":"2015"},"n_packages":2,"n_references":1,"next":{"headline":"Elasticsearch Groovy Scripting Engine Remote Code Execution","id":"CVE-2015-1427"},"packages":[{"ecosystem":"RubyGems","fixed":["2.4.1"],"introduced":["1.6.0"],"last_affected":[],"package":"facter","purl":null,"source":"GHSA-j436-h7hm-rx46"},{"ecosystem":"RubyGems","fixed":["2.4.1"],"introduced":["1.6.0"],"last_affected":[],"package":"facter","purl":"pkg:gem/facter","source":"GHSA-j436-h7hm-rx46"}],"prev":{"headline":"Other in n/a","id":"CVE-2015-1425"},"products":["n/a"],"published":"2015-02-23","related":[{"cvss_score":6.2,"headline":"facter, hiera, mcollective-client, and puppet affected by untrusted search path vulnerability","id":"CVE-2014-3248","kev_date_added":null,"published":"2014-11-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Local attackers can read sensitive Amazon EC2 IAM instance metadata via Puppet Facter, exposing credentials and configuration data.","url":"https://insights.sbomify.com/CVE-2015-1426/"}