# CVE-2015-1426: Puppet Labs Facter allows local users to obtain sensitive Amazon EC2 IAM instance metadata

> Local attackers can read sensitive Amazon EC2 IAM instance metadata via Puppet Facter, exposing credentials and configuration data.

- **Severity:** Low 2.1 (`AV:L/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Feb 2015
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-1426, GHSA-j436-h7hm-rx46, UBUNTU-CVE-2015-1426

## What is CVE-2015-1426?

CVE-2015-1426 is a low-severity vulnerability in n/a, published on 23 Feb 2015. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Puppet Labs Facter 1.6.0 through 2.4.0 allows local users to obtains sensitive Amazon EC2 IAM instance metadata by reading a fact for an Amazon EC2 node.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2015-1426?

2 open source packages ship an affected version, including facter. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `facter` | RubyGems | From 1.6.0 | 2.4.1 |
| `facter` | RubyGems | From 1.6.0 | 2.4.1 |

Products: Puppet Facter, Puppetlabs Facter.

## How do I fix CVE-2015-1426?

Upgrade facter to 2.4.1 or later.

## Is CVE-2015-1426 being exploited?

There is no known exploitation of CVE-2015-1426 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2014-3248](https://insights.sbomify.com/CVE-2014-3248/): facter, hiera, mcollective-client, and puppet affected by untrusted search path vulnerability (medium 6.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-1426 and fix it if it is affected.

What it is: CVE-2015-1426 is a low-severity vulnerability in n/a, published on 23 Feb 2015. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-1426 in the wild and no public exploit code.

Affected packages and fixed versions:
- facter (RubyGems): affected from 1.6.0; fixed in 2.4.1
- facter (RubyGems): affected from 1.6.0; fixed in 2.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-1426/ (Markdown: https://insights.sbomify.com/CVE-2015-1426/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-1426
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-1426
- OSV: https://osv.dev/vulnerability/CVE-2015-1426

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-1426/
Summaries are generated and may contain mistakes; the official description above is the record.
