# CVE-2015-1427: Elasticsearch Groovy Scripting Engine Remote Code Execution

> Remote attackers can execute arbitrary shell commands by bypassing the Groovy sandbox in Elasticsearch, requiring immediate upgrades.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 25 Mar 2022 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Feb 2015
- **Updated:** 22 Oct 2025
- **Also known as:** GHSA-w94p-6mhw-4qxw

## What is CVE-2015-1427?

CVE-2015-1427 is a critical code injection vulnerability in Elastic Elasticsearch, published on 17 Feb 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Groovy scripting engine in Elasticsearch before 1.3.8 and 1.4.x before 1.4.3 allows remote attackers to bypass the sandbox protection mechanism and execute arbitrary shell commands via a crafted script.

## Which versions are affected by CVE-2015-1427?

4 open source packages ship an affected version, including org.elasticsearch:elasticsearch. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.elasticsearch:elasticsearch` | Maven | All versions | 1.3.8 |
| `org.elasticsearch:elasticsearch` | Maven | All versions | 1.3.8 |
| `org.elasticsearch:elasticsearch` | Maven | From 1.4.0 | 1.4.3 |
| `org.elasticsearch:elasticsearch` | Maven | From 1.4.0 | 1.4.3 |

Products: Elastic Elasticsearch, Redhat Fuse.

## How do I fix CVE-2015-1427?

Upgrade org.elasticsearch:elasticsearch to a fixed version for your release line: 1.3.8 or 1.4.3. US federal agencies must fix it by 15 Apr 2022.

## Is CVE-2015-1427 being exploited?

Yes. Attackers have exploited CVE-2015-1427 in the wild since at least 25 Mar 2022.

Public exploit code:

- Elasticsearch 1.4.0 < 1.4.2 Remote Code Execution exploit and vulnerable container (github_poc): https://github.com/t0kx/exploit-CVE-2015-1427
- ElasticSearch Search Groovy Sandbox Bypass (metasploit)
- ElasticSearch - Remote Code Execution (exploitdb)
- ElasticSearch - Search Groovy Sandbox Bypass (Metasploit) (exploitdb)
- cve-2015-1427 (github_poc): https://github.com/cved-sources/cve-2015-1427
- https://github.com/cyberharsh/Groovy-scripting-engine-CVE-2015-1427 (github_poc): https://github.com/cyberharsh/Groovy-scripting-engine-CVE-2015-1427

## Other vulnerabilities in Elastic Elasticsearch

- [CVE-2014-3120](https://insights.sbomify.com/CVE-2014-3120/): Elasticsearch Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2015-5377](https://insights.sbomify.com/CVE-2015-5377/): Code injection in n/a (critical 9.8)
- [CVE-2026-72649](https://insights.sbomify.com/CVE-2026-72649/): Deserialization of Untrusted Data in Elasticsearch Leading to Remote Code Execution (high 8.8)
- [CVE-2026-72642](https://insights.sbomify.com/CVE-2026-72642/): Use of Out-of-range Pointer Offset in the Elasticsearch Machine Learning Native Inference Process (high 8.8)
- [CVE-2020-7014](https://insights.sbomify.com/CVE-2020-7014/): Privilege Escalation Flaw in Elasticsearch (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-1427 and fix it if it is affected.

What it is: CVE-2015-1427 is a critical code injection vulnerability in Elastic Elasticsearch, published on 17 Feb 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2015-1427 in the wild since at least 25 Mar 2022.

Affected packages and fixed versions:
- org.elasticsearch:elasticsearch (Maven): affected all versions; fixed in 1.3.8
- org.elasticsearch:elasticsearch (Maven): affected all versions; fixed in 1.3.8
- org.elasticsearch:elasticsearch (Maven): affected from 1.4.0; fixed in 1.4.3
- org.elasticsearch:elasticsearch (Maven): affected from 1.4.0; fixed in 1.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-1427/ (Markdown: https://insights.sbomify.com/CVE-2015-1427/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-1427
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-1427
- OSV: https://osv.dev/vulnerability/CVE-2015-1427

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-1427/
Summaries are generated and may contain mistakes; the official description above is the record.
