CVE-2015-1493 Moodle directory traversal vulnerability
Authenticated attackers can read arbitrary files, including source code, via directory traversal in Moodle.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-1493?
CVE-2015-1493 is a medium-severity path traversal vulnerability in Moodle Moodle, published on 1 Jun 2015. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Directory traversal vulnerability in the min_get_slash_argument function in lib/configonlylib.php in Moodle through 2.5.9, 2.6.x before 2.6.8, 2.7.x before 2.7.5, and 2.8.x before 2.8.3 allows remote authenticated users to read arbitrary files via a .. (dot dot) in the file parameter, as demonstrated by reading PHP scripts.
Weakness: CWE-22
Which versions are affected by CVE-2015-1493?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 2.6.8 |
moodle/moodle Packagist | All versions | 2.6.8 |
moodle/moodle Packagist | From 2.7.0 | 2.7.5 |
moodle/moodle Packagist | From 2.7.0 | 2.7.5 |
moodle/moodle Packagist | From 2.8.0 | 2.8.3 |
moodle/moodle Packagist | From 2.8.0 | 2.8.3 |
Products include Moodle Moodle.
How do I fix CVE-2015-1493?
Upgrade moodle/moodle to a fixed version for your release line: 2.6.8, 2.7.5 or 2.8.3.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2015-1493 being exploited?
There is no known exploitation of CVE-2015-1493 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as CVE-2015-0246, GHSA-gphj-63h8-r9vq, MGASA-2015-0057.