CVE-2015-1561 Centreon Command Injection
Remote authenticated users can execute arbitrary commands via shell metacharacters in the ns_id parameter due to improper input sanitization.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-1561?
CVE-2015-1561 is a medium-severity command injection vulnerability in Centreon Centreon, published on 14 Jul 2015. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The escape_command function in include/Administration/corePerformance/getStats.php in Centreon (formerly Merethis Centreon) 2.5.4 and earlier (fixed in Centreon 19.10.0) uses an incorrect regular expression, which allows remote authenticated users to execute arbitrary commands via shell metacharacters in the ns_id parameter.
Weakness: CWE-77
Which versions are affected by CVE-2015-1561?
2 open source packages ship an affected version, including centreon/centreon. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
centreon/centreon Packagist | All versions | 2.8.28 |
centreon/centreon Packagist | All versions | 2.8.28 |
Products include Centreon Centreon.
How do I fix CVE-2015-1561?
Upgrade centreon/centreon to 2.8.28 or later.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2015-1561 being exploited?
There is no known exploitation of CVE-2015-1561 in the wild and no public exploit code.
Public exploit code: 1 Exploit-DB entry.
Other vulnerabilities in Centreon Centreon
Sources
Also known as GHSA-c4fj-3wqq-g9c9.