{"answers":{"affected":"2 open source packages ship an affected version, including DotNetNuke.Core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-1566 in the wild and no public exploit code.","fix":"Upgrade DotNetNuke.Core to 7.4.0 or later.","what":"CVE-2015-1566 is a medium-severity cross-site scripting vulnerability in Dnnsoftware Dotnetnuke, published on 9 Feb 2015. It can be exploited over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2015-1566 and fix it if it is affected.\n\nWhat it is: CVE-2015-1566 is a medium-severity cross-site scripting vulnerability in Dnnsoftware Dotnetnuke, published on 9 Feb 2015. It can be exploited over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2015-1566 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- DotNetNuke.Core (NuGet): affected all versions; fixed in 7.4.0\n- DotNetNuke.Core (NuGet): affected all versions; fixed in 7.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-1566/ (Markdown: https://insights.sbomify.com/CVE-2015-1566/index.md)","id":"CVE-2015-1566","markdown":"https://insights.sbomify.com/CVE-2015-1566/index.md","name":"CVE-2015-1566","record":{"aliases":["GHSA-v76m-f5cx-8rg4"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"DotNetNuke CMS","requires_auth":"unknown","summary":"Remote attackers can inject arbitrary web script or HTML into DotNetNuke, potentially compromising user sessions or data.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"dotnetnuke","vendor":"dnnsoftware"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in DotNetNuke (DNN) before 7.4.0 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.","ecosystems":["NuGet"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moderate severity vulnerability that affects DotNetNuke.Core","id":"CVE-2015-1566","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"NuGet","product":"dnnsoftware:dotnetnuke","products":["dnnsoftware:dotnetnuke"],"type":"xss","year":"2015"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2015-1567"},"packages":[{"ecosystem":"NuGet","fixed":["7.4.0"],"introduced":["0"],"last_affected":[],"package":"DotNetNuke.Core","purl":null,"source":"GHSA-v76m-f5cx-8rg4"},{"ecosystem":"NuGet","fixed":["7.4.0"],"introduced":["0"],"last_affected":[],"package":"DotNetNuke.Core","purl":"pkg:nuget/DotNetNuke.Core","source":"GHSA-v76m-f5cx-8rg4"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2015-1565"},"products":["n/a"],"published":"2015-02-09","related":[{"cvss_score":8.8,"headline":"DotNetNuke (DNN) Remote Code Execution","id":"CVE-2017-9822","kev_date_added":"2021-11-03","published":"2017-07-20"},{"cvss_score":7.5,"headline":"DotNetNuke (DNN) Inadequate Encryption Strength","id":"CVE-2018-15811","kev_date_added":"2021-11-03","published":"2019-07-03"},{"cvss_score":7.5,"headline":"DotNetNuke (DNN) Inadequate Encryption Strength","id":"CVE-2018-18325","kev_date_added":"2021-11-03","published":"2019-07-03"},{"cvss_score":10,"headline":"DNN Insufficient Access Control - Image Upload allows for Site Content Overwrite","id":"CVE-2025-64095","kev_date_added":null,"published":"2025-10-28"},{"cvss_score":10,"headline":"Privilege escalation in n/a","id":"CVE-2006-3601","kev_date_added":null,"published":"2006-07-14"},{"cvss_score":9.8,"headline":"The installation wizard in DotNetNuke (DNN) allows privilege escalation","id":"CVE-2015-2794","kev_date_added":null,"published":"2017-02-06"},{"cvss_score":9.1,"headline":"DotNetNuke.Core Vulnerable to Stored XSS via Module Title","id":"CVE-2026-24838","kev_date_added":null,"published":"2026-01-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML into DotNetNuke, potentially compromising user sessions or data.","url":"https://insights.sbomify.com/CVE-2015-1566/"}