# CVE-2015-1566: Moderate severity vulnerability that affects DotNetNuke.Core

> Remote attackers can inject arbitrary web script or HTML into DotNetNuke, potentially compromising user sessions or data.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not stated
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Feb 2015
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-v76m-f5cx-8rg4

## What is CVE-2015-1566?

CVE-2015-1566 is a medium-severity cross-site scripting vulnerability in Dnnsoftware Dotnetnuke, published on 9 Feb 2015. It can be exploited over the network, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in DotNetNuke (DNN) before 7.4.0 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2015-1566?

2 open source packages ship an affected version, including DotNetNuke.Core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `DotNetNuke.Core` | NuGet | All versions | 7.4.0 |
| `DotNetNuke.Core` | NuGet | All versions | 7.4.0 |

Products: Dnnsoftware Dotnetnuke.

## How do I fix CVE-2015-1566?

Upgrade DotNetNuke.Core to 7.4.0 or later.

## Is CVE-2015-1566 being exploited?

There is no known exploitation of CVE-2015-1566 in the wild and no public exploit code.

## Other vulnerabilities in Dnnsoftware Dotnetnuke

- [CVE-2017-9822](https://insights.sbomify.com/CVE-2017-9822/): DotNetNuke (DNN) Remote Code Execution (high 8.8, exploited in the wild)
- [CVE-2018-15811](https://insights.sbomify.com/CVE-2018-15811/): DotNetNuke (DNN) Inadequate Encryption Strength (high 7.5, exploited in the wild)
- [CVE-2018-18325](https://insights.sbomify.com/CVE-2018-18325/): DotNetNuke (DNN) Inadequate Encryption Strength (high 7.5, exploited in the wild)
- [CVE-2025-64095](https://insights.sbomify.com/CVE-2025-64095/): DNN Insufficient Access Control - Image Upload allows for Site Content Overwrite (critical 10.0)
- [CVE-2006-3601](https://insights.sbomify.com/CVE-2006-3601/): Privilege escalation in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-1566 and fix it if it is affected.

What it is: CVE-2015-1566 is a medium-severity cross-site scripting vulnerability in Dnnsoftware Dotnetnuke, published on 9 Feb 2015. It can be exploited over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-1566 in the wild and no public exploit code.

Affected packages and fixed versions:
- DotNetNuke.Core (NuGet): affected all versions; fixed in 7.4.0
- DotNetNuke.Core (NuGet): affected all versions; fixed in 7.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-1566/ (Markdown: https://insights.sbomify.com/CVE-2015-1566/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-1566
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-1566
- OSV: https://osv.dev/vulnerability/CVE-2015-1566

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-1566/
Summaries are generated and may contain mistakes; the official description above is the record.
