CVE-2015-1772 Improper Authentication in org.apache.hive:hive, org.apache.hive:hive-exec, and org.apache.hive:hive-service
Remote attackers can bypass authentication in Apache HiveServer2 by exploiting mishandled anonymous LDAP bind configurations.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-1772?
CVE-2015-1772 is a high-severity authentication bypass vulnerability in n/a, published on 21 Dec 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The LDAP implementation in HiveServer2 in Apache Hive before 1.0.1 and 1.1.x before 1.1.1, as used in IBM InfoSphere BigInsights 3.0, 3.0.0.1, and 3.0.0.2 and other products, mishandles simple unauthenticated and anonymous bind configurations, which allows remote attackers to bypass authentication via a crafted LDAP request.
Weakness: CWE-287
Which versions are affected by CVE-2015-1772?
12 open source packages ship an affected version, including org.apache.hive:hive, org.apache.hive:hive-exec and org.apache.hive:hive-service. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.hive:hive Maven | From 1.0.0 | 1.0.1 |
org.apache.hive:hive Maven | From 1.0.0 | 1.0.1 |
org.apache.hive:hive Maven | From 1.1.0 | 1.1.1 |
org.apache.hive:hive Maven | From 1.1.0 | 1.1.1 |
org.apache.hive:hive-exec Maven | From 1.0.0 | 1.0.1 |
org.apache.hive:hive-exec Maven | From 1.0.0 | 1.0.1 |
6 more packages
org.apache.hive:hive-exec Maven | From 1.1.0 | 1.1.1 |
org.apache.hive:hive-exec Maven | From 1.1.0 | 1.1.1 |
org.apache.hive:hive-service Maven | From 1.0.0 | 1.0.1 |
org.apache.hive:hive-service Maven | From 1.0.0 | 1.0.1 |
org.apache.hive:hive-service Maven | From 1.1.0 | 1.1.1 |
org.apache.hive:hive-service Maven | From 1.1.0 | 1.1.1 |
Products include Apache Hive, Ibm Infosphere Biginsights.
How do I fix CVE-2015-1772?
Upgrade org.apache.hive:hive to a fixed version for your release line: 1.0.1 or 1.1.1.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2015-1772 being exploited?
There is no known exploitation of CVE-2015-1772 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2026-49845 Apache Hive: SQL Injection vulnerability in HiveMetaStore partition-name direct-SQL paths
- CVE-2018-21234 Deserialization of Untrusted Data in Jodd
- CVE-2026-55976 Apache Hive: SSRF vulnerability in Hive Avro Serde due to Insufficient input validation on avro.schema.url
- CVE-2018-1282 SQL Injection in hive-jdbc
- CVE-2022-41137 Apache Hive: Deserialization of untrusted data when fetching partitions from the Metastore
Sources
Also known as GHSA-5gvm-hrw5-h6xf.