# CVE-2015-1776: Exposure of Sensitive Information to an Unauthorized Actor in Apache Hadoop

> Local attackers can read sensitive intermediate data and encryption keys from disk when Hadoop's intermediate data encryption is enabled.

- **Severity:** Medium 6.2 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Apr 2016
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-g48f-ff5h-5f64

## What is CVE-2015-1776?

CVE-2015-1776 is a medium-severity vulnerability in n/a, published on 19 Apr 2016. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Apache Hadoop 2.6.x encrypts intermediate data generated by a MapReduce job and stores it along with the encryption key in a credentials file on disk when the Intermediate data encryption feature is enabled, which allows local users to obtain sensitive information by reading the file.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2015-1776?

2 open source packages ship an affected version, including org.apache.hadoop:hadoop-common. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.hadoop:hadoop-common` | Maven | From 2.6.0 | 2.6.5 |
| `org.apache.hadoop:hadoop-common` | Maven | From 2.6.0 | 2.6.5 |

Products: Apache Hadoop.

## How do I fix CVE-2015-1776?

Upgrade org.apache.hadoop:hadoop-common to 2.6.5 or later.

## Is CVE-2015-1776 being exploited?

There is no known exploitation of CVE-2015-1776 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-25168](https://insights.sbomify.com/CVE-2022-25168/): Command injection in org.apache.hadoop.fs.FileUtil.unTarUsingTar (critical 9.8)
- [CVE-2021-37404](https://insights.sbomify.com/CVE-2021-37404/): Heap buffer overflow in libhdfs native library (critical 9.8)
- [CVE-2022-26612](https://insights.sbomify.com/CVE-2022-26612/): Arbitrary file write in FileUtil#unpackEntries on Windows (critical 9.8)
- [CVE-2019-17195](https://insights.sbomify.com/CVE-2019-17195/): Improper Check for Unusual or Exceptional Conditions in Connect2id Nimbus JOSE+JWT (critical 9.8)
- [CVE-2017-15718](https://insights.sbomify.com/CVE-2017-15718/): Exposure of Sensitive Information in Hadoop (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-1776 and fix it if it is affected.

What it is: CVE-2015-1776 is a medium-severity vulnerability in n/a, published on 19 Apr 2016. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-1776 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.hadoop:hadoop-common (Maven): affected from 2.6.0; fixed in 2.6.5
- org.apache.hadoop:hadoop-common (Maven): affected from 2.6.0; fixed in 2.6.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-1776/ (Markdown: https://insights.sbomify.com/CVE-2015-1776/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-1776
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-1776
- OSV: https://osv.dev/vulnerability/CVE-2015-1776

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-1776/
Summaries are generated and may contain mistakes; the official description above is the record.
