# CVE-2015-1786: Zend Framework CSRF Vulnerability

> Attackers can bypass CSRF protection in Zend Framework by exploiting null or malformed token identifiers, potentially allowing unauthorized actions.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Jun 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-gwwq-54qp-9pgp

## What is CVE-2015-1786?

CVE-2015-1786 is a high-severity vulnerability in n/a, published on 8 Jun 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site request forgery (CSRF) vulnerability in Zend/Validator/Csrf in Zend Framework 2.3.x before 2.3.6 via null or malformed token identifiers.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2015-1786?

2 open source packages ship an affected version, including zendframework/zendframework. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zendframework/zendframework` | Packagist | From 2.3.0 | 2.3.6 |
| `zendframework/zendframework` | Packagist | From 2.3.0 | 2.3.6 |

Products: Zend Zend Framework.

## How do I fix CVE-2015-1786?

Upgrade zendframework/zendframework to 2.3.6 or later.

## Is CVE-2015-1786 being exploited?

There is no known exploitation of CVE-2015-1786 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-29312](https://insights.sbomify.com/CVE-2020-29312/): Deserialization in n/a (critical 9.8)
- [CVE-2015-1555](https://insights.sbomify.com/CVE-2015-1555/): Auth bypass in n/a (critical 9.1)
- [CVE-2015-7503](https://insights.sbomify.com/CVE-2015-7503/): Zend Framework Information Disclosure (high 7.5)
- [CVE-2014-2685](https://insights.sbomify.com/CVE-2014-2685/): Auth bypass in n/a (high 7.5)
- [CVE-2015-5161](https://insights.sbomify.com/CVE-2015-5161/): ZendXml and Zend Framework contain XXE and XEE Vulnerabilities (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-1786 and fix it if it is affected.

What it is: CVE-2015-1786 is a high-severity vulnerability in n/a, published on 8 Jun 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-1786 in the wild and no public exploit code.

Affected packages and fixed versions:
- zendframework/zendframework (Packagist): affected from 2.3.0; fixed in 2.3.6
- zendframework/zendframework (Packagist): affected from 2.3.0; fixed in 2.3.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-1786/ (Markdown: https://insights.sbomify.com/CVE-2015-1786/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-1786
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-1786
- OSV: https://osv.dev/vulnerability/CVE-2015-1786

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-1786/
Summaries are generated and may contain mistakes; the official description above is the record.
