{"answers":{"affected":"4 open source packages ship an affected version, including edu.internet2.middleware:shibboleth-identityprovider and org.opensaml:opensaml. It affects 2 products.","exploited":"There is no known exploitation of CVE-2015-1796 in the wild and no public exploit code.","fix":"Upgrade edu.internet2.middleware:shibboleth-identityprovider to 2.4.4 or later.","what":"CVE-2015-1796 is a medium-severity authentication bypass vulnerability in n/a, published on 8 Jul 2015. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-1796 and fix it if it is affected.\n\nWhat it is: CVE-2015-1796 is a medium-severity authentication bypass vulnerability in n/a, published on 8 Jul 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-1796 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- edu.internet2.middleware:shibboleth-identityprovider (Maven): affected all versions; fixed in 2.4.4\n- edu.internet2.middleware:shibboleth-identityprovider (Maven): affected all versions; fixed in 2.4.4\n- org.opensaml:opensaml (Maven): affected all versions; fixed in 2.6.5\n- org.opensaml:opensaml (Maven): affected all versions; fixed in 2.6.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-1796/ (Markdown: https://insights.sbomify.com/CVE-2015-1796/index.md)","id":"CVE-2015-1796","markdown":"https://insights.sbomify.com/CVE-2015-1796/index.md","name":"CVE-2015-1796","record":{"aliases":["GHSA-78fq-w796-q537"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Java SAML library","requires_auth":"none","summary":"Remote attackers can impersonate entities by exploiting a flaw in PKIX trust engines that accepts untrusted certificates when no trusted names are configured.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"identity_provider","vendor":"shibboleth"},{"product":"opensaml_java","vendor":"shibboleth"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-254","name":null}],"description":"The PKIX trust engines in Shibboleth Identity Provider before 2.4.4 and OpenSAML Java (OpenSAML-J) before 2.6.5 trust candidate X.509 credentials when no trusted names are available for the entityID, which allows remote attackers to impersonate an entity via a certificate issued by a shibmd:KeyAuthority trust anchor.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Certificate Validation in Shibboleth Identity Provider and OpenSAML","id":"CVE-2015-1796","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"auth_bypass","year":"2015"},"n_packages":4,"n_references":4,"next":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2015-1797"},"packages":[{"ecosystem":"Maven","fixed":["2.4.4"],"introduced":["0"],"last_affected":[],"package":"edu.internet2.middleware:shibboleth-identityprovider","purl":null,"source":"GHSA-78fq-w796-q537"},{"ecosystem":"Maven","fixed":["2.4.4"],"introduced":["0"],"last_affected":[],"package":"edu.internet2.middleware:shibboleth-identityprovider","purl":"pkg:maven/edu.internet2.middleware/shibboleth-identityprovider","source":"GHSA-78fq-w796-q537"},{"ecosystem":"Maven","fixed":["2.6.5"],"introduced":["0"],"last_affected":[],"package":"org.opensaml:opensaml","purl":null,"source":"GHSA-78fq-w796-q537"},{"ecosystem":"Maven","fixed":["2.6.5"],"introduced":["0"],"last_affected":[],"package":"org.opensaml:opensaml","purl":"pkg:maven/org.opensaml/opensaml","source":"GHSA-78fq-w796-q537"}],"prev":{"headline":"Privilege escalation in n/a","id":"CVE-2015-1795"},"products":["n/a"],"published":"2015-07-08","related":[{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2020-27978","kev_date_added":null,"published":"2020-10-28"},{"cvss_score":5.9,"headline":"Improper Validation of Certificate with Host Mismatch in Shibboleth Identity Provider and OpenSAML Java","id":"CVE-2014-3603","kev_date_added":null,"published":"2019-04-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can impersonate entities by exploiting a flaw in PKIX trust engines that accepts untrusted certificates when no trusted names are configured.","url":"https://insights.sbomify.com/CVE-2015-1796/"}