# CVE-2015-1796: Improper Certificate Validation in Shibboleth Identity Provider and OpenSAML

> Remote attackers can impersonate entities by exploiting a flaw in PKIX trust engines that accepts untrusted certificates when no trusted names are configured.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jul 2015
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-78fq-w796-q537

## What is CVE-2015-1796?

CVE-2015-1796 is a medium-severity authentication bypass vulnerability in n/a, published on 8 Jul 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The PKIX trust engines in Shibboleth Identity Provider before 2.4.4 and OpenSAML Java (OpenSAML-J) before 2.6.5 trust candidate X.509 credentials when no trusted names are available for the entityID, which allows remote attackers to impersonate an entity via a certificate issued by a shibmd:KeyAuthority trust anchor.

Weakness: CWE-254

## Which versions are affected by CVE-2015-1796?

4 open source packages ship an affected version, including edu.internet2.middleware:shibboleth-identityprovider and org.opensaml:opensaml. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `edu.internet2.middleware:shibboleth-identityprovider` | Maven | All versions | 2.4.4 |
| `edu.internet2.middleware:shibboleth-identityprovider` | Maven | All versions | 2.4.4 |
| `org.opensaml:opensaml` | Maven | All versions | 2.6.5 |
| `org.opensaml:opensaml` | Maven | All versions | 2.6.5 |

Products: Shibboleth Identity Provider, Shibboleth Opensaml Java.

## How do I fix CVE-2015-1796?

Upgrade edu.internet2.middleware:shibboleth-identityprovider to 2.4.4 or later.

## Is CVE-2015-1796 being exploited?

There is no known exploitation of CVE-2015-1796 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-27978](https://insights.sbomify.com/CVE-2020-27978/): Denial of service in n/a (high 7.5)
- [CVE-2014-3603](https://insights.sbomify.com/CVE-2014-3603/): Improper Validation of Certificate with Host Mismatch in Shibboleth Identity Provider and OpenSAML Java (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-1796 and fix it if it is affected.

What it is: CVE-2015-1796 is a medium-severity authentication bypass vulnerability in n/a, published on 8 Jul 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-1796 in the wild and no public exploit code.

Affected packages and fixed versions:
- edu.internet2.middleware:shibboleth-identityprovider (Maven): affected all versions; fixed in 2.4.4
- edu.internet2.middleware:shibboleth-identityprovider (Maven): affected all versions; fixed in 2.4.4
- org.opensaml:opensaml (Maven): affected all versions; fixed in 2.6.5
- org.opensaml:opensaml (Maven): affected all versions; fixed in 2.6.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-1796/ (Markdown: https://insights.sbomify.com/CVE-2015-1796/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-1796
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-1796
- OSV: https://osv.dev/vulnerability/CVE-2015-1796

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-1796/
Summaries are generated and may contain mistakes; the official description above is the record.
