CVE-2015-1806 Jenkins allows for Privilege Escalation by Remote Authenticated Users

Medium 6.5 Published Updated

Authenticated users with job configuration permissions can escalate privileges and execute arbitrary code on the Jenkins master.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2015-1806?

CVE-2015-1806 is a medium-severity vulnerability in Jenkins Jenkins, published on 16 Oct 2015. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

The combination filter Groovy script in Jenkins before 1.600 and LTS before 1.596.1 allows remote authenticated users with job configuration permission to gain privileges and execute arbitrary code on the master via unspecified vectors.

Weakness: CWE-264

Which versions are affected by CVE-2015-1806?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions1.596.1
org.jenkins-ci.main:jenkins-core MavenAll versions1.596.1
org.jenkins-ci.main:jenkins-core MavenFrom 1.5971.600
org.jenkins-ci.main:jenkins-core MavenFrom 1.5971.600

Products include Jenkins Jenkins, Redhat Openshift.

How do I fix CVE-2015-1806?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.596.1 or 1.600.

Is CVE-2015-1806 being exploited?

There is no known exploitation of CVE-2015-1806 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-mm9c-4cv4-7rfv.

Is CVE-2015-1806 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free