CVE-2015-1808 Jenkins Vulnerable to Denial of Service (DoS)

Low 3.5 Published Updated

Remote authenticated users can cause a denial of service in Jenkins by submitting crafted update center data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2015-1808?

CVE-2015-1808 is a low-severity denial of service vulnerability in Jenkins Jenkins, published on 16 Oct 2015. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Jenkins before 1.600 and LTS before 1.596.1 allows remote authenticated users to cause a denial of service (improper plug-in and tool installation) via crafted update center data.

Weakness: CWE-20

Which versions are affected by CVE-2015-1808?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions1.596.1
org.jenkins-ci.main:jenkins-core MavenAll versions1.596.1
org.jenkins-ci.main:jenkins-core MavenFrom 1.5971.600
org.jenkins-ci.main:jenkins-core MavenFrom 1.5971.600

Products include Jenkins Jenkins, Redhat Openshift.

How do I fix CVE-2015-1808?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.596.1 or 1.600.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2015-1808 being exploited?

There is no known exploitation of CVE-2015-1808 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-3rwx-3vwh-mwxc.

Is CVE-2015-1808 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free