{"answers":{"affected":"4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-1809 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.596.1 or 1.600.","what":"CVE-2015-1809 is a high-severity vulnerability in CloudBees Jenkins, published on 15 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-1809 and fix it if it is affected.\n\nWhat it is: CVE-2015-1809 is a high-severity vulnerability in CloudBees Jenkins, published on 15 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-1809 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 1.596.1\n- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 1.596.1\n- org.jenkins-ci.main:jenkins-core (Maven): affected from 1.597; fixed in 1.600\n- org.jenkins-ci.main:jenkins-core (Maven): affected from 1.597; fixed in 1.600\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-1809/ (Markdown: https://insights.sbomify.com/CVE-2015-1809/index.md)","id":"CVE-2015-1809","markdown":"https://insights.sbomify.com/CVE-2015-1809/index.md","name":"CVE-2015-1809","record":{"aliases":["GHSA-qj27-w92h-fc9r"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins CI server","requires_auth":"none","summary":"Remote attackers can read arbitrary XML files via XPath queries in Jenkins, requiring an upgrade to secure the CI server.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"cloudbees","vendor":"jenkins"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"XML external entity (XXE) vulnerability in CloudBees Jenkins before 1.600 and LTS before 1.596.1 allows remote attackers to read arbitrary XML files via an XPath query.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"XML external entity (XXE) vulnerability in Jenkins","id":"CVE-2015-1809","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2015"},"n_packages":4,"n_references":2,"next":{"headline":"Jenkins does not Restrict Reserved Names Allowing for Privilege Escalation","id":"CVE-2015-1810"},"packages":[{"ecosystem":"Maven","fixed":["1.596.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":null,"source":"GHSA-qj27-w92h-fc9r"},{"ecosystem":"Maven","fixed":["1.596.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":"pkg:maven/org.jenkins-ci.main/jenkins-core","source":"GHSA-qj27-w92h-fc9r"},{"ecosystem":"Maven","fixed":["1.600"],"introduced":["1.597"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":null,"source":"GHSA-qj27-w92h-fc9r"},{"ecosystem":"Maven","fixed":["1.600"],"introduced":["1.597"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":"pkg:maven/org.jenkins-ci.main/jenkins-core","source":"GHSA-qj27-w92h-fc9r"}],"prev":{"headline":"Jenkins Vulnerable to Denial of Service (DoS)","id":"CVE-2015-1808"},"products":["Jenkins","Jenkins LTS"],"published":"2020-01-15","related":[{"cvss_score":7.5,"headline":"XML external entity (XXE) vulnerability in Jenkins","id":"CVE-2015-1811","kev_date_added":null,"published":"2020-01-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["CloudBees"]},"summary":"Remote attackers can read arbitrary XML files via XPath queries in Jenkins, requiring an upgrade to secure the CI server.","url":"https://insights.sbomify.com/CVE-2015-1809/"}