# CVE-2015-1811: XML external entity (XXE) vulnerability in Jenkins

> Remote attackers can read arbitrary XML files in Jenkins via crafted XML documents, exposing sensitive configuration data.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jan 2020
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-qg7x-4h4q-3m49

## What is CVE-2015-1811?

CVE-2015-1811 is a high-severity vulnerability in CloudBees Jenkins, published on 15 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XML external entity (XXE) vulnerability in CloudBees Jenkins before 1.600 and LTS before 1.596.1 allows remote attackers to read arbitrary XML files via a crafted XML document.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2015-1811?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 1.596.1 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 1.596.1 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 1.597 | 1.600 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 1.597 | 1.600 |

Products: Jenkins Cloudbees.

## How do I fix CVE-2015-1811?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.596.1 or 1.600.

## Is CVE-2015-1811 being exploited?

There is no known exploitation of CVE-2015-1811 in the wild and no public exploit code.

## Other vulnerabilities in CloudBees Jenkins

- [CVE-2015-1809](https://insights.sbomify.com/CVE-2015-1809/): XML external entity (XXE) vulnerability in Jenkins (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-1811 and fix it if it is affected.

What it is: CVE-2015-1811 is a high-severity vulnerability in CloudBees Jenkins, published on 15 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-1811 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 1.596.1
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 1.596.1
- org.jenkins-ci.main:jenkins-core (Maven): affected from 1.597; fixed in 1.600
- org.jenkins-ci.main:jenkins-core (Maven): affected from 1.597; fixed in 1.600

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-1811/ (Markdown: https://insights.sbomify.com/CVE-2015-1811/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-1811
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-1811
- OSV: https://osv.dev/vulnerability/CVE-2015-1811

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-1811/
Summaries are generated and may contain mistakes; the official description above is the record.
