CVE-2015-1813 Jenkins allows Cross-Site Scripting (XSS)

Medium 4.3 Published Updated

Remote attackers can inject arbitrary web script or HTML into Jenkins, potentially compromising user sessions or executing malicious code.

Exploited in the wild
Not known
Login needed
Not stated
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2015-1813?

CVE-2015-1813 is a medium-severity cross-site scripting vulnerability in Jenkins Jenkins, published on 16 Oct 2015. It can be exploited over the network, and only if a user opens a file or follows a link.

Official description

Cross-site scripting (XSS) vulnerability in Jenkins before 1.606 and LTS before 1.596.2 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors, a different vulnerability than CVE-2015-1812.

Weakness: CWE-79

Which versions are affected by CVE-2015-1813?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions1.596.2
org.jenkins-ci.main:jenkins-core MavenAll versions1.596.2
org.jenkins-ci.main:jenkins-core MavenFrom 1.5971.606
org.jenkins-ci.main:jenkins-core MavenFrom 1.5971.606

Products include Jenkins Jenkins, Redhat Openshift.

How do I fix CVE-2015-1813?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.596.2 or 1.606.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2015-1813 being exploited?

There is no known exploitation of CVE-2015-1813 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-9h85-v6xf-h26q.

Is CVE-2015-1813 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free